Map cannot be used error

As has been reported by others, I am receiving the message that my USA map can't be used with this device.
I purchased this device, re-manufactured, many years ago and it has been working perfectly until a couple weeks ago. I haven't attached it to my computer in years, until now that I'm trying to figure out what happened.

It's cold here in the northeast, so I thought maybe it is having a problem being in the car all the time, but the TomTom Home app says all the tests are fine.

I tried downloading and running the flash reset utility - that did nothing. I backed up and restored, again nothing. I read somewhere about the drum reset, which I tried, to no avail.

There's nothing else wrong with the unit and I've enjoyed having it lo these last 10 years or so. I don't want to buy another if this can be reset. I have no idea what happened.

I'd appreciate any thoughts anyone might have. Thanks.

Update ** After reading other posts, I'm wondering if this is the result of Tom Tom ceasing support for this model. I don't know why that would cause the device to stop working, unless the satellites are programmed not to work with these older models?!?


Drew

Comments

  • dhndhn Posts: 32,988 Superusers
    Yes, that model has been decreed as End of Life by Tomtom. No further map updates. Sorry.
  • VikramKVikramK Posts: 6,537 TomTom Moderator
    Hi @CTDrew

    Welcome to the community!

    I reviewed your account and I see that you have an active map which can be downloaded again.

    Looking at your post it seem that the current map on your device is corrupted so I would recommend that you try removing/deleting the map using TomTom HOME, FAQ: https://uk.support.tomtom.com/app/answers/detail/a_id/6953

    Then install a fresh map which will be offered for download.

    Regards
    Vikram :)
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
  • CTDrewCTDrew Posts: 4 [Neophyte Traveler]
    Hello all, Sorry for the delayed response.

    @dhn, You are apparently correct, except that it seems the map on the device somehow updated to v. 10 (which requires a more capable model.) My device only supports map versions up to 9.6.

    I was stumped trying to figure out why my loaded version didn't match what I purchased a few years ago.

    @VikramK, Thank you!!! Your recommendation is exactly what I did. I had to, first, download the map I originally purchased (v9.6), then delete the map from the device. Finally, I loaded the newly downloaded map and the angels rejoiced. Everything is fine now. Thank you!

    So, bottom line appears to be that Tom Tom does not intentionally obsolete the old devices like mine. They have said as much, and I can say that they are true to their word.

    That said, I know I'm living on borrowed time in terms of my map and necessary updates (which I can no longer get). But at least I know Tom Tom didn't leave me high and dry - and I also know (now) that this forum works!!! Yeah!

    Thank you all so much for the assistance.

    -Drew
Sign In or Register to comment.

Who's Online17

17 Guests