Updating maps v10.20 Europe on an infinite loop

XosemaXosema Posts: 31 [Outstanding Explorer]
edited January 30 in MyDrive Connect
Hi.

Well, I have a GO60, using MyDrive Connect, of course, and my O.S. is Vista in case it matters, although I could update the device last August (I believe it was August) perfectly. Now it doesn't, otherwise I wouldn't be here.

So I went and see what updates I had waiting and there were two. First one was another small one, the kind just weights a few bytes, not KB, not MB, just a few bytes (I wonder, really, I wonder what you can update with 100 bytes, I'd love to know that). So I did that update as it just takes seconds.

And there was the big one, 8.5 GB or so. I started that update right after the other small one. I never set MyDrive to do both on its own, I prefer to see by myself each update going well... if they go well.

But just a few minutes into the update, it seems as if the device had disconnected from the laptop, although it wasn't. Note that the cable is the original one. Since it did not recover on its own, I unplugged and plugged the cable back in again and it seemed to work again.

Trouble is, now when it gets to 10-11%, it starts over again at 4-5%. I've tried rebooting the device, unplugging it, re-plug it in, killing the MyDrive process to start over, I would even delete any cache files if there were any but I don't see any.

Any suggestions? because as of now, I'm without a map in the device as all it's done is deleting the previous version.

Thank you very much in advance.

Comments

  • dmulvdmulv Posts: 550 Superuser
    Firstly, my condolences on having to use Windows Vista :cry:

    As for your problem, my next step would be to restore the device to its factory default settings (under the System menu), then re-attempt the update.

    You won'l lose your Places as they're synced to MyDrive, it'll just be any settings you've changed that you'll need to reapply.
  • YamFazManYamFazMan Posts: 13,621 Superusers
    Hi
    @Xosema

    [h3]Tomtom FAQ... Software update for Windows Vista and XP users[/h3]https://uk.support.tomtom.com/app/answers/detail/a_id/20314#vista

    ATB YFM
  • XosemaXosema Posts: 31 [Outstanding Explorer]
    dmulv wrote:
    Firstly, my condolences on having to use Windows Vista :cry:

    Thank you for your support. In both subjects.

    I'll try and see what happens. Thank you!
  • XosemaXosema Posts: 31 [Outstanding Explorer]
    dmulv wrote:
    As for your problem, my next step would be to restore the device to its factory default settings (under the System menu), then re-attempt the update.

    There's a problem with that. Since the installation process did actually began (although never going beyond 20%, it seems it goes a littler further now but far from finishing anyway) there's no map in the device now. So, there's only this message on the screen telling me that and that I should try and install whatever map I may have or purchase a new one. There's no way, at least none that I know, to go to the menu. Is there something I don't know?

    Thank you.
  • XosemaXosema Posts: 31 [Outstanding Explorer]
    YamFazMan wrote:
    Hi
    @Xosema

    [h3]Tomtom FAQ... Software update for Windows Vista and XP users[/h3]https://uk.support.tomtom.com/app/answers/detail/a_id/20314#vista

    Thank you, but as far as I know, that's not the problem I'm having. If I've read that correctly, that article is about making MyDrive detect the device after an update. And that is something that I had to do, or something similar, last year (I believe that article is from last year if I saw the right date).

    But it's been working fine until now. The only problem I've had lately is that my SD was not big enough for the map to be stored and, since maps cannot be divided between the SD and the internal memory (with, really, I believe that should be something they should allow to do) I had to buy a bigger SD. But that is all.

    As I said before, I could do the full update last august with no problem at all, and just before doing this big update, I could do a smaller one as well with no problem whatsoever.

    So, it seems something is stuck somewhere but I don't know how to get it un-stuck.
  • dhndhn Posts: 33,058 Superusers
    Support:

    :flag_es: España (Spain)
    913496596
    Lunes-Viernes: 09:00-17:30
  • XosemaXosema Posts: 31 [Outstanding Explorer]
    I'm starting to think it's MyDrive what's not working properly. I've done a reset to the device by holding the On button for a few seconds (it played the bongos, then an MS-DOS-like window appeared with data info about the device, then the start up screen showed up again and the bongos again.)

    But it turns out that MyDrive, for whatever reason, as soon as it detects the device, it says it's installing at 11%, even when the device is still loading. It takes a while until it goes up to 19% and, after another while, it goes back to 11. Rinse and repeat.

    Is there anyway I can "reset" MyDrive other than reinstalling it? I also feel that if I reinstall the program, maybe there are some files left somewhere that would render that reinstallation useless... and one would think that, in case those files exist somewhere, removing them would be enough for MyDrive to work properly again without the need for reinstallation.

    I may be wrong but... anyone?

    Thank you!
  • XosemaXosema Posts: 31 [Outstanding Explorer]
    Well, I've tried a few things and it still won't update, although it's a different thing now.

    I noticed that MyDrive said there was like 4GB free in the SD card, although it had not finished the process. At once it also said it had 2GB free. So I took the card out and read it in the laptop, which said it was empty. I don't know if maybe it just didn't recognize the data, but if the device uses its own file system, then the pc should not recognize it, and it did, so I went (which seems to be a mistake now) and formatted the SD card as a 16GB FAT32 system.

    Anyway, I went and try and reinstall the map in the device, and it's been so many times that I'm not certain about this, but I believe it kept trying to install even when the card was not in the slot. It went until the end and then it remained stuck in the "checking" after a 100%. So I had to turn everything off and on again.

    But then I tried and install the map in the internal memory (no sd card installed). The problem is that my map is Europe and the only combination that fits in the internal memory is Europe with Scandinavian buildings... which is quite pointless for a Spaniard but if it has to be, it has to be, as the Europe without buildings map is even heavier than the rest as, as I learned later, it turns out that map has no buildings but it has Russia instead (funny).

    And here I am, I've tried a few times now, with rebootings and you name it, but now instead of going into a loop, it just goes until 20% or so and it says there's an error and, should it happen again, I have to visit www.tomtom.com/support

    The funny thing is that now, since the formatting, MyDrive does not recognise the SD card, although I know the device knows it's there as the DOS-like window when I reset the device says so. I even had the chance to choose if I wanted the card to be used for routes or maps, but that was not automatic, I did choose "maps" but I think it didn't care as it is not recognized by MyDrive yet.

    And here I am, after two errors updating the device... I'm not certain what's what I can do.

    Yes, I know I can wait until monday and call tech support, but I wanted to solve this sooner.

    Thank you.
  • XosemaXosema Posts: 31 [Outstanding Explorer]
    Well, things have changed but still not much.

    I can't remember all the things I've done already, but since it was failing over and over again to update, I went and cleared the cache (which is funny since I had reinstalled MyDrive again) and now there was this message on top of the app with a black background saying something like there was not enough disk space for the update to download. So I went to the configuration and set the download location on another partition and it started downloading right there.

    Two hours later (for whatever reason, the update is supposed to be 6.something GB but it downloads two files with 6.something and 6.somethingElse GB respectively, and I'm on a 20MB/s connection at the moment) it tries to install it but it's stuck "waiting for your device". Well, it's in Spanish so it says "Esperando al dispositivo", but you know that.

    However, the device says "Updating () Do not disconnect your navigator" where the parenthesis are a poor man's updating circle. Well, and in Spanish.

    I've looked for answers in the forum but I can't find any that works. Yes, I've unplugged and replugged the device quite a few times, resetted it as well... I don't know what else I could do.

    Any suggestions? they're absolutely welcome.

    Thank you.
  • XosemaXosema Posts: 31 [Outstanding Explorer]
    Funny!

    I left the GO60 plugged, since I saw that someone had said it had eventually worked. So I went and watched some videos.

    And just after a few minutes, I realised the navigator had the screen saying "the update has been finished, ACCEPT" or something like that. I tapped on it and it's installed correctly. I don't know how or why but it worked... even less so when MyDrive was saying there was some error somewhere.

    However, checking again from the main menu in MyDrive, now it all was fine.

    Or almost, as now I had on the screen a message in order to choose whether I wanted the SD Card to be used for maps or routes (I chose maps, obviously) and it is now that MyDrive recognises the card again (which, I remind you, it was because I formatted the card in my laptop just in case it was corrupted or whatever, not remembering that any SD Card that is used by the navigator has to be formatted by the navigator itself. I know it has to do with proprietary software and whatnot, but it's a bit of a downside).

    The problem now is that I have the Europe map with Scandinavian buildings, and I'm a bit of a fan of Deep Purple's, but I'm not expecting a travel to the northen territories any time soon, so right now it's installing the full Europe map.

    It's going to take a while but I wanted to write this down now just in case someone else replied my previous comment.

    Thank you.
Sign In or Register to comment.

Who's Online128

DougLap
DougLap
Henri1952
Henri1952
Hofi53
Hofi53
Leika
Leika
Lorenzo550
Lorenzo550
WoBla
WoBla
+122 Guests