tomtom not responding after format

Mike007Mike007 Posts: 2 [Apprentice Traveler]
Hi

I tried to update my tomtom with didn't go to well. It wouldn't let me open any of my maps.

Followed support advice on the site, telling me to do a manual backup and to format my tomtom. Done that. Then it said to reinstall software. This is the fun part. I connect my device to my computer expecting tomtom desktop software to read my device so i can update it. But now tomtom home can not read my tomtom. But my computer see's it as a drive.

please help. :(

Comments

  • dhndhn Posts: 32,866 [Superusers]
  • Mike007Mike007 Posts: 2 [Apprentice Traveler]
    Yes I have tried those steps. But am not sure about the root directory location.

    What i read up online, was that on finder locate your device. Open the device and install folder there. Which is the root directory of the tom tom. Is that correct?

    Thing is that nothing happened when i opened the tom tom home or when i restarted the application and the device. I followed every step.

    It can't be the cable that am using because before i formated the tomtom i was using the same cable.

    But just incase, is there a certain usb cable that needs to be used. Unfortunately i don't have the cable which came with it.

    help please
Sign In or Register to comment.

Who's Online39

Anna Ampel
Anna Ampel
Casper78vfr
Casper78vfr
Gangster_Bulk
Gangster_Bulk
Lochfrass
Lochfrass
marco692
marco692
oe5psl
oe5psl
Peter Combes
Peter Combes
scheibenklar
scheibenklar
Ste7ios
Ste7ios
tbiekens
tbiekens
YamFazMan
YamFazMan
+28 Guests