Update to 4.2.3.3625 fails with message about TempMDC.lnk — TomTom Community

Update to 4.2.3.3625 fails with message about TempMDC.lnk

GerardTrompGerardTromp Posts: 21 [Master Explorer]
edited January 2019 in MyDrive Connect
Today I was informed that there was an obligatory update (popup from within MyDrive Connect). Tried to update. Progress bar got to about 75 or 80% and then an information message popped up indicating that there was no associated app to complete the process for something relating to the TempMDC.lnk file.

Tried uninstalling and reinstalling MyDrive Connect. That worked fine but it was 4.1.7.nnnn (newly downloaded today 2018-11-12). And soon after starting the program, a popup appeared indicating that there was an obligatory update. Failed at exactly the same point in the update.

I finally found that the update process does not play well with ACL permissions. That is, running the process as an administrator (elevating permissions) does not successfully execute the update. It appears that a sub-process is launched that does not have the administrator privileges.

When one logs in using an administrator account the update works fine. That is, all process, including sub-processes will inherit administrator permissions.

Solution:
  1. Log into an administrator account (if necessary, create a new user and assign administrator status).
  2. Launch MyDrive Connect
  3. Wait for update notice (one to several minutes)
  4. Execute update.

The error really suggests that the update process needs to be investigated to ensure that all processes inherit the appropriate administrator permissions (would be trusted installer permissions).
Sign In or Register to comment.

Who's Online in this Category0