Rider 410 Screen is unresponsive

Springhill
Springhill Registered Users Posts: 3
Apprentice Traveler
edited January 2019 in RIDER
After riding through a substantial rain/hailstorm, unfortunately the following day the screen had condensation inside.
Some days later after using moisture beads to try and dry the GPS out I plugged it into the computer and it downloaded a number of updates without any issue.
I then turned it on and it fired up but none of the screen buttons worked, tried the turn off and reset several times to no avail.
I am in Western Australia and wonder if there is anyone that has recovered their Rider 410 from this problem.

Comments

  • JoelS.
    JoelS. Registered Users Posts: 317
    Exalted Navigator
    yep, i have ran into this a couple times now.
    i was on a trip in the mountains both times.

    my post, last of the second thread

    "Just Had the same condensation, loss of touch about a week ago. Took a few nights in rice, and riding in the sun. I was on a trip, and fought my route 1 afternoon because I couldn't select the 2nd part of it. Happened on a trip once in april also. Rider 400 here, thinking I'll bag it in the rain.
    Gathering there is no prevention with the current unit, say remove the trim, or adding to the sealing area, or pushing down around the trim?"

    my other post asked what to do on a trip, put it in rice, rode a few days, each day it got better, 1st thing in the morning i could pick a route, then the condensation would appear again on and riding. thus buttons quit working. sometimes rotating i was able to put the button i wanted in a different and possibly clear location.
  • TImG65
    TImG65 Registered Users Posts: 23
    Master Explorer
    This happened a year ago, custservs “repaired” device. I’m touring on Spain and it’s done it again. This is REALLY annoying. Anyone got a fix !