TomTom Traffic not working

Bill2013
Bill2013 Registered Users Posts: 10
Apprentice Seeker
edited January 2019 in TomTom Services
I have just recently had my TT6100 replaced underwarrenty, now I find my TomTom Traffic has stopped working, i.e. I get message saying My subscription expired on 04/10/2018.
As far as I was laid to believe this service was Life Time on the TT6100, so why is it telling me it has expired ??
Thanks

Comments

  • Niall
    Niall Posts: 11,140
    Superuser
    @Bill2013

    Contact Customer service to sort out your subscription(s) maybe they forgot to transfer traffic details


    :flag_gb: United Kingdom
    02079 490 132
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • Bill2013
    Bill2013 Registered Users Posts: 10
    Apprentice Seeker
    Thanks Niall, I have just called them and it does look like they forgot to transfer the service. Now I await an email to confirm it.
    Best regards
    Bill
  • Niall
    Niall Posts: 11,140
    Superuser
    @Bill2013

    Glad that was helpful

    Hopefully you traffic subscription will be up and running in a few minutes
  • Bill2013
    Bill2013 Registered Users Posts: 10
    Apprentice Seeker
    Hi Niall, I have just noticed something rather odd.
    My old TomTom6100 which was supposed to be replaced under warranty has not been replaced with a TomTom6100 but with a TomTom6000.
    I was just checking the paper work which came back with the replacement and it says replaced a 6000. i had better go back to them.
  • Niall
    Niall Posts: 11,140
    Superuser
    @Bill2013

    "QQ">GO 6000 / 6100, 8GB + micro-SDHC, MyDrive Connect NAV4

    So they may be the same, but check that all your subscriptions have been transferred and are lifetime
  • Bill2013
    Bill2013 Registered Users Posts: 10
    Apprentice Seeker
    Thanks again Niall, we are all sorted now, been told both 6100 and 6000 are the same, and now I have the Traffic back on line
    Best regards
    Bill