Cannot copy new route or track to the Tomtom device

cristo Registered Users Posts: 16
Apprentice Traveler
edited January 2019 in RIDER
This was a working system that previously updated and accepted Mydrive routes without issue.

New Issue:
I cannot copy new routes/tracks to the Rider EXCEPT via SD Card which works with no issues. Below I identify confirmed statuses and outcomes from troubleshooting.

Rider Connections:

It connects to my Smartphone Bluetooth hotspot
-- It connects to Tomtom Services via Smartphone bluetooth tethered hotspot
It connects to my PC via USB
-- It connects to PC My Drive
-- It can be seen in Windows Explorer

Operations via USB Connection
Updated Rider via Mydrive - maps and software are fully up to date
-- ISSUE: Cannot save a route from MyDrive to Rider

Windows Explorer
When connected to PC I can see the rider in explorer and copy a route FROM the Rider TO my PC
-- ISSUE: Cannot Copy route FROM PC TO Rider (after pressing "import routes" on rider)
Symptom: Continues to copy and never finishes. Files are not present on device.

SD Card
Copied route from PC to SD card. Inserted SD in Rider and imported routes and tracks with no issue,

  • Drumroll (soft) reset complete
  • Various combinations of restarting PC/RIder etc.
  • Exporting from applications and windows explorer - none will Copy TO the rider.
  • I cannot connect to Tomtom Services over USB (but its fine via smartphone)
I cannot determine which (windows 10 installation) driver is responsible for this connection so am unable to update/reinstall driver.

I'd appreciate any advice on why I cannot update routes from the PC.


  • Ste7ios
    Ste7ios Posts: 759
    Great troubleshooting!

    You may try it on another computer to see if it’s something with your computer or not.

    If it’s not your computer you may do a factory reset.
  • YamFazMan
    YamFazMan Posts: 20,814

    Are you logged into 'MyDrive' on the device ???
    Tap 4Dot (.... menu) --> Tomtom Services --> MyDrive... Login with your Tomtom Account Email & Password

  • cristo
    cristo Registered Users Posts: 16
    Apprentice Traveler
    Hi YamFazMan

    Thanks for your response.
    I put a lot of work into explaining clearly the steps I have gone through in the original post therefore as per original post:
    • I cannot connect to Tomtom Services over USB (but its fine via smartphone)
    However, for file transfer via windows explorer I don't believe it is necessary to be connected to Tomtom Services anyway so the issue is not on the device. It is likely to be due to an issue on the PC (as per STe7ios post) but I don't have another PC to try it on at the moment.

    It would be helpful if someone could explain how I can re-install the relevant driver on the PC as that is the logical next step. Would it be removed if I uninstall MyDrive and then reinstall - you probably don't know and it would be better if I can just reinstall the driver on its own if that is possible?

  • YamFazMan
    YamFazMan Posts: 20,814

    OK then, I guess It's safe to assume your logged into MyDrive on the device...

    Manually install Tomtom Drivers
    If Windows is unable to locate the driver or Device Manager shows an error coder 28
    Plug your Tomtom into the USB port and turn it on (device needs to be connected for the divers to show in Device Manager)
    Click Start
    Right-click My Computer (or Computer)
    Click Manage.
    In the Computer Management window, on the left, click Device Manager.
    Click on Network Adapter
    Click the + sign in front of the device category for which you wish to install the driver
    Note... If there is a yellow question mark the driver is definitely missing or corrupt
    Right click on TomTom

    Note... On my system, it can be Tomtom, Tomtom #2, #3, #4 etc...I own several Tomtom devices
    Note... On my Win10 PC, its listed as Remote NDIS Compatible Device #2, #3, #4 etc...

    Right-click the device, and select Update Driver. The Hardware Update Wizard opens.
    For using Windows Update, select No, not this time and click Next.
    Select Install from a list or specific location (Advanced), and click Next.
    In the window for search and installation options, select Search for the best driver in these locations, and select the Include this location in the search checkbox.
    Click Browse, and navigate to the folder that contains the driver files.

    MyDriveConnect installs the Tomtom Driver files here.....
    C:\Program Files\MyDrive Connect\Driver
    Folder... INF
    Folder... win32
    Folder... x64

    Click OK when the appropriate folder is selected.
    Back in the Hardware Update Wizard, click Next
    Windows will search for the driver and install it automatically
    When the installation is complete, click Finish

  • YamFazMan
    YamFazMan Posts: 20,814

    Tomtom... 'Easy route upload'
    The Rider 4xx/5xx will give you direct access to a small buffer/transfer area of the Rider 400 Main Memory... You can also access your Micro SD Card, you can drag & drop your .ITN or .GPX route files directly to and from the Rider 400 Memory buffer/transfer area or the Micro SD Memory card over a secure system
    You don't have to have to use the Micro SD Card as a transfer medium

    Transfer a .ITN or .GPX route file/s to your NAV4 device using a Micro SD Memory Card...See.....

    Transferring a route to my PC using Bluetooth (Or a Micro SD Card)
    Tap (.... Menu) --> MyRoutes --> Share Tracks --> select the Recorded Route
    --> Tap Share --> Choose Memory card or Bluetooth --> Follow the on-screen prompts to completion.....

  • cristo
    cristo Registered Users Posts: 16
    Apprentice Traveler
    Hi Yamfazman

    Thanks for identifying the driver for me. The issue appears to be fixed.
    The following process was followed (as your instructions could not be precisely followed):
    1. Reinstall Driver opened device manager
    2. plugged in Rider and observed the Remote NDIS Compatible Device driver dynamically load into device manager
    3. tried to update driver hwoever windows reported it was up to date and would do nothing so stepped back and clicked uninstall driver. Then unplugged Rider and rebooted PC.
    4. Plugged in Rider and observed Windows loaded driver automatically (Did it really uninstall it - not sure!)
    5. pressed 'import routes' on Rider and observed Remote NDIS Compatible Device driver was removed and a USB controller device "USB Composite Device" loaded - I was expecting this as for file transfer using explorer it is a standard USB operation so as suspected does not require the specific NDIS driver
    6. tested route copy onto device (worked fine - so appears to have fixed this issue
    7. Checked Tomtom Services Mydrive and it now appears to be activated (this would only work via bluetooth to phone previously)
    8. MyDrive is now fully connecting as all data is synching correctly
    9. I have also downloaded a route from MyRouteapp successfully
    Issue appears to have been a corrupted driver and is now fixed - long may it stay so!
    Many thanks for your timely support and I hope this helps anyone else with the same issue.

  • YamFazMan
    YamFazMan Posts: 20,814

    Glad to see you're sorted :relaxed: