ADDRESS BOOK and making phone calls RIDER 550 — TomTom Community

ADDRESS BOOK and making phone calls RIDER 550

chris24pcchris24pc Posts: 3 [Apprentice Traveler]
edited January 25 in RIDER
I have recently connected my Rider 550 to my iPhone X and my N-Com B901K helmet comms. When I turn my helmet comms on I get the voice message "phone connected" and a few seconds later "device connected". I can set a route on the Rider and listen through my helmet perfectly. When I first set it up I got a telephone icon on the TomTom screen, which allowed me to press and get Siri asking what I wanted. This is really handy as I can phone anyone without fiddling around with buttons on the side of my helmet. However, I am not now getting the telephone icon anymore. When my phone rings I can hear it in my helmet and by saying "hello" I can answer the call so I know it is all connected properly, but without the icon I can't make any calls.
Any suggestions would be appreciated.

Comments

  • AymaraAymara Posts: 19 [Apprentice Traveler]
    Try if it helps to delete all bluetooth profiles on the Rider and the iPhone and start the pairing from scratch ... it might help.
  • chris24pcchris24pc Posts: 3 [Apprentice Traveler]
    Thank you Aymara, I have already done that a few times. Today I managed to get the phone icon on the screen. It is something to do with having 'my drive' running on my phone. I'm pretty sure the bluetooth connection between all 3 devices is OK.
    I just don't want to have to keep fiddling with it when I go out on my bike.
    Thank you again.
  • AymaraAymara Posts: 19 [Apprentice Traveler]
    In my case no fiddling at all ... btw, I start MyDrive before switching on Bluetooth on the phone and I make sure, that I‘m out of reach of the WiFi before.

    PS: If all else fails you can also use the mobile hotspot on the phone to connect the Rider by WiFi to the phone to just get MyDrive access and Traffic. Then switch off Bluetooth on the Rider and use telephony only with the headset. This is what I do in my car to use telephony on my car‘s bluetooth only. Ok, it is a workaround, but has the advantage, that you don‘t need GPS on the phone which spares battery power drastically.

    PS: I‘m still on iOS 11.4.1 ... if you‘re on iOS 12 already ... that is buggy as hell as it seems.
  • AymaraAymara Posts: 19 [Apprentice Traveler]
    There‘s one thing, I forgot, and which I didn‘t find documented anywhere, for example not here:

    http://uk.support.tomtom.com/app/answers/detail/a_id/23302/~/connecting-your-phone-for-data%2C-hands-free-calls%2C-and-smartphone-messages

    You have two TomTom Rider bluetooth connections on your iPhone and one of them allows further settings, when tapping on the „i“ (info). Here you can switch on „synchonisation“ of contacts / address book and recent call.

    I knew that setting from my car‘s bluetooth and switched it on, though the R550 no longer syncs the address book. I did it, because I saw, that name resolution sometimes didn’t work. But the later has a different reason as I already found out.

    The MyDrive app has a contact menu, that imports your phone contacts, if you allow it, BUT only those contacts, that have an address, at least a town!

    So maybe try above bluetooth setting and make sure the MyDrive app has all needed access rights (contacts, Siri, notifications) in the settings app.
  • chris24pcchris24pc Posts: 3 [Apprentice Traveler]
    Thank you Aymara, I think you have made a good point about being out of Wi-Fi range. I usually turn everything on when I get in my garage, but I have a very strong Wi-Fi signal there. Maybe I'll wheel the bike out to the street before turning on.
    I'll keep fiddling and post any fix that I find.
    Again, thank you for your advice:thumbsup_tone3:
  • AymaraAymara Posts: 19 [Apprentice Traveler]
    WiFi in the garage is a common phenomenon, so I already told it the German forum moderator, who addressed it to TT Support. WiFi urgently needs a switch off button !!!

    It‘s unbelievable and unacceptable, that we need to stop away from home to get Bluetooth running without issues.

    I would recommend deleting the WiFi in the Rider and only reconnect it once a week to check for updates. That‘s a workaround until TT fixes this B*llsh*t.

    PS: Alterantively keep the Rider switched off, until you are out of WiFi range and only switch on headset and phone Bluetooth in the garage. But that is also unacceptable, if you sent nav points (a new route) to the Rider, that you directly want to drive.
  • Ste7iosSte7ios Posts: 726 Superuser
    From the moment they'll add a switch to fix that problem the game is lost...

    They can do some clever things to keep it fully automated and keep power consumption to a minimum.

    Like:
    • Disable WiFi when not in home (Home's WiFi or / and other location).
    • Disable WiFi when pairing with BlueTooth.
  • AymaraAymara Posts: 19 [Apprentice Traveler]
    Ste7ios wrote:
    • Disable WiFi when not in home (Home's WiFi or / and other location).
    • Disable WiFi when pairing with BlueTooth.

    The second might be an idea, but the first one isn‘t sufficient, as above garage example shows.

    But power consumption is definitely something to consider too, yes.
Sign In or Register to comment.

Who's Online37

DougLap
DougLap
Elchdoktor
Elchdoktor
prout
prout
tgold
tgold
+33 Guests