Carminat Navigation (in a Renault) SD card not recognized after update — TomTom Community

Carminat Navigation (in a Renault) SD card not recognized after update

ral31ghral31gh Posts: 2 [Apprentice Traveler]
Hey there -

I recently purchased a 2012 Renault Megane with TomTom/Carminat Navigation. I've wanted to update the maps so I bought a card reader, ejected the SD card and proceeded to install the software on my computer and update the SD card.

After the update was successful, I put the SD card back into the Navigation center and it's telling me it's not recognizing it. I continuously get screen prompts to eject and reinsert the SD card.

When I go and try to restore my SD card to the backed up version, my TomTom Home won't recognize that the device is connected to my card reader (even when my computer recognizes that the SD is connected - since I can see folder contents).

I'm not sure what to do since this is my first ever experience with TomTom/Carminat.

Any help or insight is greatly appreciated.

Thanks in advance,
Raleigh

Comments

  • vla_donvla_don Posts: 2 [Apprentice Traveler]
    Once you have working SD card you can make a copy of it following procedure described in this post: https://en.discussions.tomtom.com/built-in-car-navigation-25/problem-with-maps-on-sd-card-557110/index1.html#post558294
    This way you can have working navigation all the time even with an older map version.
  • ral31ghral31gh Posts: 2 [Apprentice Traveler]
    I've tried the above to no avail.

    Basically, what seems to be the major issue is my TomTom program that's installed on my computer appears to be faulty. I purchased a brand new SD card in hopes that the TomTom program would be able to read, or at the very least, recognise the SD card.
    Welp, that didn't work. I have even uninstalled and reinstalled the program several times.

    I've copied all files from the factory issued SD card to the new one and the TomTom program says that there is still no device connected. It's becoming annoyingly frustrating to say the very least. As when I put the factory issued SD card in the very first time ever, the TomTom program recognised it. Now...nothing.

    Has anyone run across this before? Am I better off taking it back to a dealer to help me fix the problem?

    P.S. - I also meant to clarify from my initial post, that I'm in Australia and my factory SD card has the AU/NZ label on it.
Sign In or Register to comment.

Who's Online25

Bembo
Bembo
Elchdoktor
Elchdoktor
Geogee
Geogee
jackholman
jackholman
oe5psl
oe5psl
Rainer1246
Rainer1246
sirkarl
sirkarl
tom57
tom57
+17 Guests