GO Mobile app does not run in background - Samsung S9 / Android 8.0.0 — TomTom Community

GO Mobile app does not run in background - Samsung S9 / Android 8.0.0

CallumWCallumW Posts: 1 [New Traveler]
Hey all.
Most of the time I use the app connected by bluetooth to my helmet when riding my bike.
I have the screen off in my pocket and listen to the voice instructions as I travel, but since upgrading my phone from an S6 to an S9, I can no longer get it to run in the background.

I switch off the screen then silence ... I stop a couple of minutes down the road, unlock the phone and the app isn't running.

It worked fine on the S6, but the S9 seems more aggressive in killing background apps (good for battery life)

The phone's "Device Maintenance" / Performance is set to Optimised.

The phone's "Device Maintenance" / Battery is set to MID and I added GO to the unmonitored apps list so it can use all the power it needs

Comments

  • MotobirotariaMotobirotaria Posts: 1 [Apprentice Traveler]
    Yes! This happens to me!

    I upgraded from a Samsung Galaxy S5, to the S9. And now Go's navigation is useless. The other day, it said "turn left" and then half an hour later, as I was about to arrive at my destination, it said it would take about half an hour to get there. It had been asleep for almost the entire trip. It didn't direct me, or warn me of speed limits, or anything. I have no idea what might have been displayed on the screen during that time, as the device was charging in the glove compartment of my motorcycle.

    Even on the old S5 it was very bad at running in the background. If I started navigation, then went to Google Play Music or Audible, then back to Go to check it was on track... Go would start up again from scratch.

    My subscription runs out in a fortnight. I'll uninstall if this isn't fixed. I'll have to make do with Google Maps, which is better in many ways, even if it doesn't check your speed.
Sign In or Register to comment.

Who's Online in this Category0