My Drive Connect not working after update

Hydrocarbon
Hydrocarbon Registered Users Posts: 2
Apprentice Traveler
edited January 2019 in MyDrive Connect
Hi all
Went to update maps today (18/08/2018) which I haven't done for some time.
Opened my drive connect (MDC)- which prompted update required.
After update (4.2.2.3561) MDC would not work. Does not bring up initial screen or connect to go510.
Icon shows on task bar but it will not open page when left clicked and has no functionality if right clicked.
It shows as running in Task manager but will not End Task. Have to shut computer down to turn off.
Have wasted hours on multiple uninstalls (using Revo as well) and installs and scouring forums for solution.

Computer details -
System Manufacturer Dell Inc.
System Model Venue 11 Pro 7139
OS Name Microsoft Windows 10 Pro
Windows 10 Version 10.0.17134 Build 17134
Processor Intel(R) Core(TM) i5-4300Y CPU @ 1.60GHz, 1601 Mhz, 2 Core(s), 4 Logical Processor(s)
Installed Physical Memory (RAM) 8.00 GB

Please recommend solutions to rectify.

Comments

  • LAURE123
    LAURE123 Posts: 1,632
    Superuser
    Hi @Hydrocarbon

    During the installation of MyDrive Connect MDC do you have an error message?

    Your version Windows10 Build 17134 is a version for the Program Insider (Beta tester). The latest official Windows 10 version is 1803 published on April 30, 2018.
    It may be worth thinking to launch your Windows Update to update your system. The 1803 works very well for me. But it's you who decide what you want to do or not on your PC.

    You can try to uninstall MDC, do a Restart of your PC (Not Shut down or Sleep) then directly download and install the latest version MDC 4.2.2.3561, take it here:
    - On this page, at the bottom, the green button "Download for Windows®":
    https://www.tomtom.com/en_gb/mydrive-connect/
    - Or here directly from TomTom official servers:
    http://cdn.sa.services.tomtom.com/static/sa/Windows/InstallTomTomMyDriveConnect.exe

    If the MDC icon is completely unusable it complicates things. Check if it is still frozen after a PC Resart (Not Shut down or Sleep).
    If not you can try this procedure, it is still valid, OpenGL Desktop is simply become OpenGL Dynamic.
    https://uk.support.tomtom.com/app/answers/detail/a_id/25716


    If nothing works, you can download the downgrade version 4.1.8.3408 here directly from the official TomTom servers:
    http://cdn.sa.services.tomtom.com/static/sa/versions/InstallMyDriveConnect_downgrade.exe

    This version is built like the previous before january 2018 with Visual C++ 2010. It doesn't force the update of the software, it will leave you quiet.
    Double- click on the file, the installer will remove the MDC present on your PC before installing the downgrade version.

    I hope this will help you.

    Regards.
  • dhn
    dhn Posts: 33,381
    Superuser
    Curious. Do you have an antivirus protecting your computer and can you temporarily disable it? Then try again.

    Support:

    :flag_au: Australia
    1300 135 604
    Monday-Friday:9:00 am to 5:30 pm AEST
  • Hydrocarbon
    Hydrocarbon Registered Users Posts: 2
    Apprentice Traveler
    Thanks for your informative replies Laurie and dhn.
    I did try switching AV and firewalls off and also tried the downgrade version without success.
    What finally worked for me was doing a windows restorehealth.
    Must have been a corruption somewhere in the operating system.

    Cheers