Speed Camera update alerts not working

raypeters
raypeters Registered Users Posts: 4
Neophyte Traveler
edited January 2019 in TomTom Services
SPEED CAMERA UPDATE After a recent update I noticed that my sat nav was not recognising speed cameras anymore? Before the update it was fine and warned me about cameras, average speed etc etc. I checked in settings and everything is on. The sound is fine and working. With this sat nav I have lifetime speed camera updates. Can anyone help to explain why this has happened and what can be done about it.

Comments

  • VikramK
    VikramK Administrators Posts: 13,815
    Moderator
    Hi raypeters

    Welcome to the community :)

    I would first recommend that you do a soft reset(press and hold the on/off button till you hear the drum sounds), plan a route and test the device.

    If that does not resolve the issue then try reinstallation.

    Remove Speed Cameras-https://uk.support.tomtom.com/app/answers/detail/a_id/6830

    Install Speed Cameras-https://uk.support.tomtom.com/app/answers/detail/a_id/24138

    Soft reset again and plan a route.

    Regards
    Vikram :)
  • raypeters
    raypeters Registered Users Posts: 4
    Neophyte Traveler
    Hi Vikram

    Thank you, I tried all what you said. First the soft reset but that didn't work. I then removed the cameras. Then re installed. I then planned a local route with a speed camera but it still didn't show or warn me about the camera?

    So still not sure what has gone wrong or how to fix it?

    Regards raypeters
  • AllyG
    AllyG Registered Users Posts: 1
    Apprentice Traveler
    I'm having the same issue :( Updated my Tomtom 5200 this week, and now only 2 of the many camera on the M25 between Junctions 8 & 11 are showing up on my satnav. Very annoying! I have had a look on map share reporter and they are on there, but definitely not coming up on my satnav.
  • raypeters
    raypeters Registered Users Posts: 4
    Neophyte Traveler
    Hi I ended up calling TomTom directly about this problem. They were very helpful and their advice was to log in again on the actual sat nav and that worked. My advice is call them they can guide you through this with ease. My camera is now operating correctly. Good luck
  • Susymac
    Susymac Registered Users Posts: 1
    Apprentice Traveler
    I have got lifetime updates on my TomTom but can no longer access the camera alerts. It appears I now have to buy this function???? I would appreciate some help on this.
    Many thanks
  • Niall
    Niall Posts: 11,115
    Superuser
    @Susymac

    Contact Customer Services to check on the status of your subscription(s)


    :flag_gb: United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • raypeters
    raypeters Registered Users Posts: 4
    Neophyte Traveler
    Niall
    best advice call Tom tom customer service
  • garychapman
    garychapman Registered Users Posts: 4
    Apprentice Traveler
    I to have lost all speed camera alerts recently, for no reason!!
  • Jonwalter
    Jonwalter Registered Users Posts: 6
    Master Traveler
    There are indeed differences in how we alert for speed cameras in different countries due to their local legislation. Please, see the following link for more information tile:

    TomTom Speed Camera service and the law

    Regards
  • Jamestarbard
    Jamestarbard Registered Users Posts: 4
    Apprentice Seeker
    i constantly have this problem usually after i update. i update use it find i don't have them then update again and they return
  • Merlinonline
    Merlinonline Registered Users Posts: 1
    Apprentice Traveler
    Go into the settings and switch them back on, I was missing a speed cameras for a few days because the update switched them off
  • MarkTadley
    MarkTadley Registered Users Posts: 9
    Master Explorer
    I currently have a GO600 and it's been a brilliant SatNav etc but over the last year or so, every time I do a Speed camera update, I get the same problem that it never wants to notify me of them.

    My work-around solution to this continuing problem is to do a full turn off and back on (drum roll sounds) and then log out of my account on the SatNav and relog back in.

    Once all the above has completed, I know I can either do a short trip where I know a fixed camera is or simply wait until I need to do a normal daily commute around the big carpark - the M25.

    I actually forgot to have to do this on the latest Speed Camera update and had 3 days of no warnings and was about to call TomTom CS when I remembered this work-around.

    Hope this may help other TomTom users out if they have the same issues. :grinning::thumbsup:
  • N3v
    N3v Registered Users Posts: 1
    Apprentice Seeker
    hi I'm having trouble restoring speed camera on my tomtom GO620 ,tried calling and email but no help
  • DougLap
    DougLap Posts: 9,868
    Superuser
    HI @N3v

    Maybe @VikramK can check the unit settings . Look back here later

    Doug
  • VikramK
    VikramK Administrators Posts: 13,815
    Moderator
    Hi @N3v
    Welcome to the community! No problems with the subscriptions for your GO 620.
    The issue might need you to try some advanced troubleshooting steps. Please check-in touch with our customer service team and they should be able to guide you further.

    Regards, Vikram