My Drive will not transfer planned trips to my Go520 anymore. — TomTom Community

My Drive will not transfer planned trips to my Go520 anymore.

DucDuc Posts: 35 [Master Explorer]
Tried to enter and transfer trip to GO520 by using MyDrive. Both Mydrive and Device logged in OK, however, trip did not appear on my GO520.
The trip planning worked OK in the past but somehow it does not work anymore. Any suggestions beside a TomTom Drum Reset, my ears are starting to hurt:joy:.
Furthermore, I also recently noticed that Speed Cameras intermittently are not showing up. I do my weekly Speed Camera update OK and do a Drum Roll reset after the installation.
Had this device for about a year and it has been the most unreliable bit of cr*p I have wasted my money on. It is a bit of one step forward and two steps back.
I could go on a bit more but there is no point.
There are better options available these i,e Waze, Google Maps etc. This will be my last TT device after having owned 3 previous models.


  • YamFazManYamFazMan Posts: 19,429

    Check your connection method....
    Tap 4Dot (....Menu) --> Settings -->System --> About... Scroll down to 'Data connection'

  • DucDuc Posts: 35 [Master Explorer]
    Hi YamFazMan,

    Checked in "About" and scrolling down it tells me that "Data Connection is WiFi.

  • YamFazManYamFazMan Posts: 19,429

    Checked on my GO 520 (Wifi)
    Created a route using the MDW Route planner
    Data Connection is WiFi
    Logged into the MDW Route planner & MyDrive on the device

    Send to device.. Synced OK
    Save & Sync ... Worked OK

    How much Free Memory space does your GO 520 (Wifi) have... 400MB is considered the bare minimum
    Tap 4Dot (....Menu) --> Settings -->System --> About... Scroll down to 'Free scpace'

    Have you tried USB Transfer....
    Transferring routes using your NAV5 (Wi-Fi) device over USB will require "MyDrive Connect"
    Get it here.....

    Run MyDrive Connect.....
    Note... The NAV(5 Wifi) devices have no access the MyDrive Menu structures as used by the previous NAV3 & 4 devices
    MyDrive Connect will only show a "Splash screen" saying "Connect your device using Wifi" etc
    If required You can close the 'Main Mydrive Window' showing the "Connect your device using Wifi" Splash screen... MyDrive Connect only needs to run in the background on the PC TaskBar

    Connect your Device to a USB Port on your PCe
    Send the planned route as normal using the MDW Route planner menu options

  • DucDuc Posts: 35 [Master Explorer]
    H YFM, am currently travelling in NW Australia, poor comms. Will test again when back in Perth. Found another issue. Little compass is not working properly either. Hit and miss, mostly miss. And the problems roll on, sometimes losing bluetooth connection after going to sleep. Only way to get it to work is de- install and re- install of app. And ofcourse, reboot after reboot. I used to have a TT8200 (?) with built in sim, unfortunately sim not supported anymore in Oz. More the pity. Was very happy with that unit.
  • YamFazManYamFazMan Posts: 19,429

    It’s not a Compass as such it's a Direction of travel indicator

    It works on exactly the same principal as the one that Captain Jack Sparrow uses to navigate the Black Pearl

    When you are driving the small Arrow head chevron, above the plus and minus signs
    points to your Direction of travel

    If you imagine you are looking at a Paper Map of the World and your located in the UK

    The North-Pole is at the top and the arrow points Up ................... You're heading North
    The South-Pole is at the bottom and the arrow points down ...... You're heading South
    Canada is on the Left (West) and the arrow points Left ............... You're heading West
    China is on the Right (East) and the arrow points Right ............... You're heading East

    And obviously, all points of the compass in between, as in the example

    Greenland is halfway between Up and Left and the arrow points 45 degrees between Up/Left
    When the Tomtom arrow is pointing 45 degrees Up/Left you're heading North West

  • DucDuc Posts: 35 [Master Explorer]
    Thanks YFM, makes sense.
    BTW, it is still not transferring my trips to my unit. Am logged in OK.
    Might have to, reluctantly, do a complete system reset....
  • YamFazManYamFazMan Posts: 19,429

    The MDW Route planner has two transfer options

    'Send to device'
    The 'Send to Device' quite literally means send the planned .ITN Route to the device
    it doesn't store the route in MyRoutes

    See this thread.... For using .ITN Routes

    'Save & Sync'
    See this post.... for using .GPX Tracks

  • DucDuc Posts: 35 [Master Explorer]
    Hi YFM, who said miracles don't happen....well, without changing anything would you believe that transferring a trip to my 520 works now OK. I can use the PC version as well as the app on my mobile; they both work now and b*ggered if I know why? Anyway, thank you for your help. One thing still intrigues me, the double car symbol on the 520 still shows as not connected, however, on my mobile it shows as connected. Not sure why.
Sign In or Register to comment.

Who's Online in this Category0