Language problem

Damo1
Damo1 Registered Users Posts: 1
New Traveler
edited December 2021 in Devices using MyDrive Connect
How can I have my Tom Tom in English, using a Luxembourg address. I use a UK address at the moment so that I can have it in English, but it's not correct. I would really like to use my luxembourg base but in English
Help
Damo1

Comments

  • dhn
    dhn Posts: 33,382
    Superuser
    Sorry, but I'm not clear. Your device doesn't contain your address so I'm not sure what the issue is. Can you elaborate please?
  • gogogadget
    gogogadget Registered Users Posts: 4
    Apprentice Traveler
    For hardware (as it is in my device at least):
    Settings -> Language & Units -> Language (Interface language)
    Settings -> Language & Units -> Country (on cold start it will show the capital)

    TomTom website however - that's another story. I came here because I want the website (including support) to talk to me in English although I don't live in England (!). As for now TomTom website has chosen to speak to me in French - free of charge, but out of line, as I want it in English. Cookies? deleted! Cache? deleted. Browsing history? deleted.
    I admit, I clicked once some stupid "take me there", but it did not say it will change to French. I cannot understand why it is so difficult to offer languages and locations independently. The translations are all done, so where is the problem? (it's a rhetorical question).
  • dhn
    dhn Posts: 33,382
    Superuser
    Call support again:

    :flag_lu: Luxembourg
    +33 1 7036 3582
    lundi-vendredi: 10h00-17h30

    Agents are supposed to be able to speak English.