'Something went wrong' when attempt to access routes using MyDrive for Android app, also 'Send to De — TomTom Community

'Something went wrong' when attempt to access routes using MyDrive for Android app, also 'Send to De

mrmax67mrmax67 Posts: 8 [Legendary Explorer]
Purchased a GO 520 about 3 weeks ago. 520 and MyDrive setup on my Pixel 2 phone worked perfectly and specifically was able to transfer routes from phone to 520 using MyDrive app flawlessly.

For about a week now, when I plan a route using the MyDrive app on my phone and try to send it to my 520, the app indicates the route has been synced with MyDrive, but the route does not appear on my 520. Also, when I try to access My Routes from the MyDrive app menu, a MyDrive window pops up in the App saying 'Something went wrong' and when I close that window I'm left on an empty My Routes page.

When I logon MyDrive from a PC I don't see the Route that I attempted to sync with the MyDrive App, but am able to generate and sync routes to the 520 from the PC. Those routes do not appear on the Android App.

I've tried Shutdown/Restart on both phone and 520. I've tried uninstall/reinstall of the MyDrive app on my phone. I've also confirmed that the Android App is logged into my TomTom account.

Any other suggestions?


  • mrmax67mrmax67 Posts: 8 [Legendary Explorer]
    I've also deleted and reestablished the Bluetooth link between the 520 and the phone.
  • mrmax67mrmax67 Posts: 8 [Legendary Explorer]
    Displays on both 520 and phone indicate active Bluetooth link.
  • mrmax67mrmax67 Posts: 8 [Legendary Explorer]
    My phone OS is Android 8.1.0 and the TomTom MyDrive for Android app seems to be up to date (v2.1.0).
  • NiallNiall Posts: 10,893

    Are you logged into MyDrive on your 520 during all this?
  • mrmax67mrmax67 Posts: 8 [Legendary Explorer]
    Yes, the MyDrive (Cloud) icon in the upper right corner of the Menu page indicates I'm logged onto MyDrive ( no 'x') and the MyDrive settings page indicates I'm logged onto the correct account (correct email address).
  • mrmax67mrmax67 Posts: 8 [Legendary Explorer]
    Also am able to successfully transfer routes to the 520 from a PC when logged onto MyDrive.

    It seems to me that the problem is with the Android App.
  • mrmax67mrmax67 Posts: 8 [Legendary Explorer]
    That is, with the Android App's connection to MyDrive.
  • dhndhn Posts: 33,345
    Perhaps support:

    :flag_us: United States
    Monday - Friday: 9:00 a.m. to 7:00 p.m. EST
  • mrmax67mrmax67 Posts: 8 [Legendary Explorer]

    Spoke to Support yesterday and ultimately the CSR concluded that the Android App is probably affected by the same known bug affecting the iOS App, which the Development Team is reportedly working to address and should be corrected in a forthcoming update.


    Thanks for the advice, all.


  • YemblePhoneYemblePhone Posts: 13 [Apprentice Traveler]
    Also getting exactly the same error in the Android MyDrive v2.2.1 app when trying to save a route to TomTom Go Mobile on the same phone. There is no issue saving and syncing to My Places, the issue is only with My Routes.
Sign In or Register to comment.

Who's Online in this Category0