Battery Life after charging Start 60

Rodger Dodger
Rodger Dodger Registered Users Posts: 2
Apprentice Traveler
edited December 2021 in Devices using MyDrive Connect
I charge up the Start 60 but it quickly discharges and I then have a dim screen until it is fully charged again. Would a mains (220v) adapter charge it quicker or the Fast Charge car adapter be any quicker than the standard supplier car charger? Thanks in advance for any help.

Comments

  • Niall
    Niall Posts: 11,174
    Superuser
    @Rodger Dodger

    Are you using a USB port in your vehicle?
    As the USB ports in your vehicle provides only 0.5Amps whereas your device should have 1.2Amps to run AND charge the battery. With a vehicle USB port the reduced power means that the device tries to save it's power requirements by dimming the screen, reducing power to the SIM thus dropping traffic info, and, as you have found out, it then powers off rather than going to sleep.
    The charger must be rated at 5V 2amps [or use a PC USB port (not a laptop)] as the device draws 1.2amps
    To check that your charger is working get a USB meter for £2.99 from Amazone3d0c364-acbc-414b-9fa6-78abb277e452.jpg
    Try plugging the original cable into the original cigarette lighter charger, does it then keep shutting down?
  • Rodger Dodger
    Rodger Dodger Registered Users Posts: 2
    Apprentice Traveler
    Wow, Niall, thank you so much for the help. I use the in car charger that it came with. I will check to see what output it is rated at. Would I be best charging from the USB port on desktop or using the 220v mains charger to charge it up and then when I get the hire car use the usb in that until I can charge it up on mains? Would the fast car charger be governed by the output of the USB I suppose.
  • bensplace
    bensplace Registered Users Posts: 1
    Apprentice Traveler
    Mine has the same problem but the USB and car chargers are both the correct power rating and it doesn't matter which cable i use, i suspect it the the satnav its self
  • YamFazMan
    YamFazMan UKPosts: 21,480
     Superuser
    Hi
    @Rodger Dodger
    @bensplace

    Try using the Tomtom supplied cable and Tomtom supplied Power Adapter
    The Charger Adaptor and USB Cable supplied by Tomtom WILL run and charge the device at the same time

    Many 3rd party Mismatched Charger Adaptors won't run and charge the device at the same time
    See... It's not simply a power thing.....
    https://en.discussions.tomtom.com/go-5xxx-6xxx-series-go-4xx-6xx-series-go-via-and-start-4x-6x-series-mydrive-connect-176/go-61-brightness-problems-1025607?postid=1177429

    ATB YFM