iPhone TomTom GO app can't download a map — TomTom Community

iPhone TomTom GO app can't download a map

gerwoodgerwood Posts: 2 [Apprentice Seeker]
I've downloaded and installed the GO app from the App Store, It starts and the "Download a Map" screen shows, but then it immediately says "Oops - Something has gone wrong". And that's it: no help, no info, no links. The "Try again" button doesn't work. All I can do is stop the app. Done all the usual things (deleted/reinstalled/restarted/reset settings/different AppleID/cleaned iPhone/etc., etc.)

I did have the app installed before, then deleted it. Has something been left behind that prevents a new install from working?

(Don't want to reset my whole iPhone, btw.)

How can I install and use this app?cffca101-7fb2-4826-a3dd-e85d121f8ad5.png

Comments

  • R_BoastR_Boast Posts: 1 [Apprentice Traveler]
    I am having the same problem, but I have had Tom Tom Go (Android) for some time now. All of a sudden, I can't download new maps. I have tried on both wifi and 4G (I have loads of Gigs), but I get the same error you are getting.
  • dhndhn Posts: 33,185 Superusers
    Support numbers:

    :flag_gb: United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

    :flag_it: Italia
    0245281004
    lunedì-venerdì: ore 09:00-17:30 CET
  • gerwoodgerwood Posts: 2 [Apprentice Seeker]
    For the record the only solution was to completely reset my iPhone.
Sign In or Register to comment.

Who's Online26

GreatLakesTONY
GreatLakesTONY
Jo67
Jo67
Justyna
Justyna
kork
kork
Lost_Soul
Lost_Soul
Nigel A
Nigel A
YarisHSD
YarisHSD
+19 Guests