Rider 550 wiring — TomTom Community

Rider 550 wiring

johnnyboy1969johnnyboy1969 Posts: 4 [Neophyte Traveler]
edited January 2019 in RIDER
Bought the new tomtom and fitted the mount to my bike. The cables (for now) have been wired direct to the battery. Problem is that it does not appear to be charging the device.

Anyone else suffered from this ?

other than connecting the cables to the mount is there something that i have missed ?

thanks in advance

Comments

  • Ste7iosSte7ios Posts: 752
    Superuser
    If the polarity is correct then you may have a faulty charge mount. Contact with support.

    I can tell from what you told that this connection is temporary but it’s always nice to remind that this way the battery will get discharged. A relay / switched power is necessary to avoid this problem.
  • johnnyboy1969johnnyboy1969 Posts: 4 [Neophyte Traveler]
    understood re switched power, wanted to ensure it was all working before a more permanent solution.
  • YamFazManYamFazMan Posts: 18,464
    Superusers
    Hi
    @johnnyboy1969

    I don't know if Motorcycle Mount has Reverse Polarity Connection protection ???
    but if it hasn't, it will only takes a Nanosecond with a Reverse connection to zap the unit

    ATB YFM
  • johnnyboy1969johnnyboy1969 Posts: 4 [Neophyte Traveler]
    YamFazMan wrote:
    Hi
    @johnnyboy1969

    I don't know if Motorcycle Mount has Reverse Polarity Connection protection ???
    but if it hasn't, it will only takes a Nanosecond with a Reverse connection to zap the unit

    ATB YFM
    Not sure what you mean ?

    I have ensured that it is wired to the correct polarity, have ordered a replacement mount to see if I have a dud !
  • YamFazManYamFazMan Posts: 18,464
    Superusers
    Hi
    @johnnyboy1969

    The Rider 550 is still under Warrantee
    Ring Support and ask for a replacement

    :flag_gb: United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

    ATB YFM
  • johnnyboy1969johnnyboy1969 Posts: 4 [Neophyte Traveler]
    Just a quick question, where does the actual TT device show that the mount is charging ? Does the battery symbol change in the same way that it does when plugged into USB ?
  • YamFazManYamFazMan Posts: 18,464
    Superusers
    Hi
    @johnnyboy1969

    Tap the 4Dot (.... Menu) button... On the Menu Screen top right is a battery status Icon

    Charging... Displays when Connected to a Power supply
    368fa599-f465-4a45-9274-b2b29b56a6d1.jpgFull Charge... Displays when Connected or Not Connected Power supplyebebfcff-7cf3-43d5-9479-ef4b7f2a85ed.jpgHalf Charge... Displays when NOT Connected Power supply5c45ac4c-1a65-45a0-9b3b-8b88879a94cc.jpgLow Battery... Displays when NOT Connected Power supply29b0c6f3-11f1-4d8f-9543-eef314472a31.jpgOne of the worst things you can do to a Lithium battery is to run it flat so at a certain percentage of discharge (Unspecified)... The device will go into 'Power Saving Mode' the screen will dull, and the device will eventually turn itself off (Not Sleep)

    There is a Battery Status display available on the devices Status Screen
    Press and hold the on/off button until you hear a drum-roll sound Continue to hold the on/off button until the Black & White Status screen is shown.....
    c3623f43-813f-4ddf-9e35-af42824c5331.jpg
    If you are worrying about the device charging, you might consider one of these gadgets
    63a11bd6-9bcb-49ec-b71b-9223d7c334dd.jpgOr

    b23e2fef-ffbf-4127-80b0-646533d6f987.jpg Simply plug the device into the USB socket and plug your lead into the USB Doctor, the device will display the Voltage and Power being used by your various USB devices
    I have one of each type they're only peanuts to buy, search Amazon/eBay for USB Doctor

    ATB YFM
Sign In or Register to comment.

Who's Online in this Category0