Is anyone having difficulty uploading activity onto app today?

Lizzie2809 Registered Users Posts: 1
New Traveler
edited January 24 in TomTom Sports
Hi I tried syncing my run today from the watch to the app but only my steps have uploaded. The watch was working fine while I was running but for some reason I can’t get it to load. Really annoying because it was the fastest run I’ve done for ages since a back injury! Typical that it’s this one that’s lost and not one of my slower ones! Any help or advice will be greatly received


  • Niall
    Niall Posts: 11,113

    Expect it is all the French updating their maps before the major change of most of the roads from 90Kph to 80Kph tomorrow :)
  • Andyb71
    Andyb71 Registered Users Posts: 13
    Outstanding Explorer
    Yes, I've got exactly the same with my runner 3, won't synch since friday. Someone else has also posted the same problem.

    The watch connects to my phone absolutely fine, it starts to synch and then after about 30% just gives a message saying "Unable to Sync" then stops.

    I also tried physically connecting to my iMac and through the app there and it does the same.

    Was absolutely fine earlier in the week when I last synched to my phone, bit rubbish