MyDrive connect problem with Windows 10 — TomTom Community

MyDrive connect problem with Windows 10

James from BelgiumJames from Belgium Posts: 4 [Neophyte Traveler]
edited January 2019 in MyDrive Connect
I recently acquired a new desktop computer, running Windows 10. When I tried to install and use MyDrive Connect to update my TomTom maps, I found that my GO 6100 device, plugged into a USB port, was listed on the MyDrive Connect screen as not being connected.

After conducting an intensive internet search, I found that other TomTom users had been experiencing (similar?) problems with Windows 10. I tried many of their suggested remedies, as well as those taken from the TomTom web pages, namely:

· Connecting the USB cable directly to the PC, not through a USB hub, and not using the windshield mount provided with the GO 6100
· Trying several USB ports, with several different USB cables
· Resetting the TomTom device, by holding down the ON/OFF switch until the drum roll
· Uninstalling the MyDrive Connect software and its associated data files, uninstalling my VPN4ALL software, deactivating my ZoneAlarm Extreme Security firewall and anti-virus, and then reinstalling MyDrive Connect.

Since none of these actions were effective, I contacted TomTom Support (French-language department). Their initial response, received after a few days, was basically to suggest the various measures listed above, even though I had already explained in my written request that these were not effective.

I therefore pursued my own investigations. First – and most importantly – I discovered that when I installed MyDrive Connect on my laptop PC, running Windows 7, I was able to connect the GO 6100 normally and update my maps without any problems. Note that this laptop shares the same router and Ethernet connections with the desktop, and runs much of the same software, including VPN4ALL and ZoneAlarm Extreme Security firewall and anti-virus, which I had not removed from the laptop or deactivated.

Second, on the Windows 10 machine, I noted that the TomTom was listed in the Device Manager, under Network Adapters, as being a “Remote NDIS Compatible Device” (with an exclamation mark in a yellow triangle), i.e. there was no specific entry for a TomTom GO 6100, unlike the case of the Windows 7 laptop.

On clicking on the Properties tab of the Remote NDIS Compatible Device, on the Windows 10 machine, the General tab stated that “Windows is still setting up the class configuration for this device. (Code 56)”. Furthermore, pressing the Driver Details button on the Driver tab returned the statement that the necessary driver files were “C:\Windows\System32\Drivers\mdismp6.sys” and “C:\Windows\System32\Drivers\usb80236.sys”. Somewhat surprisingly, when I pressed the Update Driver button, I received the response “Windows has determined that the best driver for this device is already installed”.

I then checked posts on various forums to try and identify what was causing the Code 56 error. In some cases, this was attributed to the use of a Checkpoint VPN. But, as I stated above, uninstalling my VPN software did not help.
So I wrote again to the French-language TomTom Support, outlining my latest observations and queries. Very rapidly, I received a response saying that my explanations indicated that the problem was due to Windows, since I had been able to update my TomTom device using a different PC. I was therefore advised to contact Microsoft’s Technical Support.

Well, I certainly do not deny that my problem is related to Windows – and indeed apparently to Windows 10. Nevertheless, if there is an incompatibility between the TomTom hardware and Windows 10, then it would seem reasonable for TomTom to work together with Microsoft to resolve the issue. After all, Windows 10 is no more or less than the latest version of the world’s most popular operating system – and (according the forums) I do not seem to be the only TomTom MyDrive Connect user having a problem with Windows 10. On the other hand, I can hardly imagine that Microsoft Technical Support would be keen to spend much time trying to resolve an issue with a TomTom GO 6100 and MyDrive Connect, since these are only one example (out of many thousands – or millions?) of third-party hardware and software that their designers wish to run harmoniously using Windows 10. So, I interpret the brief response from French-language TomTom Support as being merely a desire to close the case without putting in any more effort.

Perhaps my correspondent at TomTom also felt that I no longer had any reason to bother her, since I had been able to update my maps using a Windows 7 PC. Well, considering that I had spent more than a whole day trying unsuccessfully to resolve the problem, I was curious to discover what was preventing satisfactory operation under Windows 10. Also, Windows 7 and my old laptop that runs it will not be around forever.

Finally, I am by no means an IT specialist and I find it unacceptable today to have to resort to trying to elucidate how to rectify abstruse “Code 56” situations in order to use a popular and widespread commercial satellite navigation device. After all, you do not need to have in-depth expertise in automobile mechanics to drive a car…

Comments

  • James from BelgiumJames from Belgium Posts: 4 [Neophyte Traveler]
    Many thanks for your reply, dhn, but I have tried unsuccessfully all these measures suggested on the TomTom Support website several times over the last week or so. I am convinced that the crux of my problem is the “Windows is still setting up the class configuration for this device. (Code 56)” message coming from the "Remote NDIS Compatible Device" Network Adapter. But I am at a loss to know how to deal with it.
  • LAURE123LAURE123 Posts: 1,632
    Superuser
    Hi all

    @James from Belgium
    I have read that you have uninstalled your VPN which can actually block your TomTom. But also that you had ZoneAlarm Premium. For anti-virus firewalls temporary deactivation does not always work, the protection remaining active in the background. This is my case with Kaspersky Security.
    You must completely stop or uninstall the software. Personally I chose to make a total exception for MDC and TT devices that are considered network adapters.

    Your problem is the detection and installation of the TT driver.
    ZoneAlarm can block it if it is not set to accept new networks as trusted or safe.
    Sometimes installing the network before the firewall solves the problem.

    In principle when a driver has an exclamation mark in a yellow triangle it must be uninstalled and the PC restarted to validate the change in Windows 10.
    A clean installation must be redone (also MDC)

    Watch this message for complete:
    https://en.discussions.tomtom.com/go-wi-fi-6200-5200-620-520-52-professional-via-53-go-camper-go-basic-482/tom-tom-go-520-not-recognised-by-the-computer-1035430/index1.html#post1219530

    I'm just trying to give you some ideas to find a solution to your problem. I'm not sure of their effectiveness.

    Regards.
  • James from BelgiumJames from Belgium Posts: 4 [Neophyte Traveler]
    Many thanks, LAURE123! Your reply put me on the right track and enabled me to solve the problem. First of all, I followed the procedure in the video to which you provided a link. But the driver updater just timed out and I received a message merely stating that a problem had been encountered. However, when I tried YamFazMan's troubleshooting procedure, outlined in the discussion you referenced, an error code 0x8000FFFF was returned. After some searching for information on this type of error, I was inspired to reboot in safe mode with networking. I then went through the driver updating procedure again and the correct driver was installed instantaneously. Furthermore, there is no longer an exclamation mark in a yellow triangle against the Remote NDIS Compatible Device entry in the Network Adapters listed in the Device Manager. Above all, MyDrive Connect now tells me that my GO 6100 is connected to the PC. Thanks again for your help! James
  • LAURE123LAURE123 Posts: 1,632
    Superuser
    @James from Belgium

    Great! Very glad for you. :slight_smile:

    You have found the solution by yourself. Safe mode with the network is a good way to neutralize the firewall and antivirus. I should have thought about it.

    Error Code 0x8000FFFF: Don't have troubles with Windows Updates on this PC?

    Regards.
  • James from BelgiumJames from Belgium Posts: 4 [Neophyte Traveler]
    Thanks again, LAURE123, for the tip about Error Code 0x8000FFFF. I ran the Windows 10 Update Troubleshooter, which returned the message "Service registration is missing or corrupt: Fixed". But when I reviewed my automatic update history, I found that the only failed updates reported were those for Windows Defender, which I had turned off, since I was already running both ZoneAlarm Extreme Security and Malwarebytes Anti-Malware.

    Do you think that the Error Code 0x8000FFFF had anything to do with the previous failure of my TomTom GO 6100 to show as connected in MyDrive Connect, or is it an entirely separate issue?
  • LAURE123LAURE123 Posts: 1,632
    Superuser
    Hi @James from Belgium

    Not easy your question, I am a simple user like you and I don't have enough knowledge to really answer you. The best I can say is I don't think so, but I'm not sure. :wink:

    The first error code (Code 56) is generally related to a network blocking problem by a VPN or a firewall. Despite the yellow triangle your TomTom device was well identified as a network adapter, with the correct label "Remote NDIS Compatible Device". Automatic detection was done but blocking the addition of the new network did not allow the procedure to be terminated. What you did, by neutralizing the firewall with safe mode.

    Error Code 0x8000FFFF: I think it was a different problem that was blocking Windows Solution auto search. Which did not help things.
    Now, you had a real Windows Update problem since the Windows Troubleshooter had something to repair. And fortunately it worked immediately. This should be monitored during your next Windows updates and if you need to use automatic driver search.

    That's a thing that happen. I had a Windows Update error message, different from your, 2 months ago on a PC in W10 and 5 months ago on another one in W7. And I don't know why. As for you, the Windows Troubleshooter solved the problem. What is annoying is that Mr Microsoft doesn't always explain in detail these error codes...

    Regards.
  • gabmambgabmamb Posts: 2 [Apprentice Seeker]
    hello everyone, I just bought a tomtom rider 500 and also I have connection problems between mydrive connect and the tomtom with windows 10; I don't have a yellow exclamation mark on "remote NDIS compatible device" but the software cannot connect (to tomtom). in the internet settings I noticed that it appears as Ethernet3 (my motherboard has two ethernets) "public network" "no network access". can the problem be here?
    can you help me? tomtom service is obscene!
    obviously I have already followed the tutorials countless times that have no effect and the responses of the email assistance are ridiculous and automatic!
  • gabmambgabmamb Posts: 2 [Apprentice Seeker]
    3fp70nhtbfcl.jpg
  • YamFazManYamFazMan Posts: 19,431
    Superusers
    edited April 2020
    Hi
    @gabmamb
    Welcome to the site....
    I would start with a fresh install of MyDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller then Reinstall MyDrive Connect....
    Using the Method Here... https://discussions.tomtom.com/en/discussion/comment/1682074/#Comment_1682074
    ______________________

    Or... Instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program... To be just as effective for giving MyDrive Connect a CPR...
    See... https://discussions.tomtom.com/en/discussion/comment/1686214/#Comment_1686214
    ______________________

    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.


    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

    Stay Safe... ATB YFM
Sign In or Register to comment.

Who's Online in this Category0