Rider 550 screen goes blank — TomTom Community

Rider 550 screen goes blank

ZliukaZliuka Posts: 5 [Novice Seeker]
edited January 2019 in RIDER
Hi, When driving Rider 550 screen goes blank and after a few seconds come back to normal driving screen. Screen looks exactly the same, just positioning triangle has been moved under speed and road name window at the bottom of the screen. After next blank-life cycle, positioning triangle moves back where it should be. The faulty unit has been replaced by Tom Tom to the new one, and new one does exactly the same trick. I updated both units to the latest software. First unit has been restored to the original software after fault was discovered, but fault was still there.
The unit connected to the Samsung phone via bluetooth and running of the battery power while on the motorcycle.
Noticed, that when unit in my car it was performing faultlessly (again running from its own battery). This weekend going to Prague in my own car. Will be a good time to test it again.

Comments

  • PathfinderSPPathfinderSP Posts: 2 [Apprentice Traveler]
    Just purchased a new Rider 550 (upgrade from Rider 400) and during all my rides I too get the same problem. I'm using power from the bike and have tried it in landscape as well as portrait mode - still the same. The blank screen appears for about 2 seconds then the map is restored. I have returned one 550 for a replacement but on the first ride with the replacement, exactly the same thing happened!
    Now my brother is getting the same problem on his Rider 450 after the most recent software update.
    Anyone got any ideas?
  • EXPORTMANEXPORTMAN Posts: 634
    Superusers
    Hi

    This is a know issue, some think it is the auto rotation so you could try locking the orientation ( Menu-Settings-appearance-display )
  • PathfinderSPPathfinderSP Posts: 2 [Apprentice Traveler]
    Thanks Exportman.
    If I get a chance tomorrow I'll give that a go. If it doesn't work I'll raise a support request with TomTom. That way at least I'm another stat for this problem
  • ZliukaZliuka Posts: 5 [Novice Seeker]
    EXPORTMAN wrote:
    Hi

    This is a know issue, some think it is the auto rotation so you could try locking the orientation Menu-Settings-appearance-display


    Will try. Thank you.
  • ZliukaZliuka Posts: 5 [Novice Seeker]
    EXPORTMAN wrote:
    Hi

    This is a know issue, some think it is the auto rotation so you could try locking the orientation Menu-Settings-appearance-display


    It works. No blinks anymore. Problem sorted. Thank you.
  • Erling KristiansrnErling Kristiansrn Posts: 2 [Apprentice Traveler]
    But does this mean that the software can’t be used as it is supposed to, if you want to turn the gps during riding?
  • YamFazManYamFazMan Posts: 18,445
    Superusers
    Hi
    @Erling Kristiansrn

    There's also a correlation between the angle that the device is mounted and Auto screen switching, the flatter the device is mounted, the more likely you are to have problems with the screen switching

    ATB YFM
  • Ste7iosSte7ios Posts: 752
    Superuser
    And the position on the bar. The center is the best.
  • Erling KristiansrnErling Kristiansrn Posts: 2 [Apprentice Traveler]
    Thanx, I really expect this expensive GPS to handle that the position is on one side of the handlebar.
  • StripyStripy Posts: 2 [Apprentice Traveler]
    Yeah, its been known for a couple of releases. Latest have seen also, that mid-navigation, the demo video will be displayed. #fail
    Not worked out, how to stop that happening...
Sign In or Register to comment.

Who's Online in this Category0