START 25 lifetime map update FAIL

DavePedder
DavePedder Registered Users Posts: 2
Apprentice Traveler
edited January 2019 in MyDrive Connect
I have made sure the MyDrive Connect software is up to date.
The 1010 map update loads OK onto my computer.
During transfer from my computer to the START 25 it all goes wrong!
Mydrive Connect says my device is not responding.
My START 25 says Something has gone wrong...

I have disconnected and reconnected the START 25 several times .
I have cleared the cache and redownloaded the europe 1010 map OK.
I am using the USB lead supplied with the START 25.

I have never managed to get the START 25 to load past the 15% completion stage!

This is the second time I have updated the map --- first time was time consuming but it did work. This time I am at a loss.

Can anyone help --- until I get this sorted the START 25 won't even get past its first 'splash' screen.

Comments

  • dhn
    dhn Posts: 33,382
    Superuser
    Call support to help:

    :flag_gb: United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • DavePedder
    DavePedder Registered Users Posts: 2
    Apprentice Traveler
    Well after tearing my hair out I finally got it to work as follows.

    Found a link that described how to reset the START 25.
    Simply press and hold down the power button until the TOMTOM drum roll can be heard.

    Once I'd done this I connected the START 25 to the computer again.
    Everything worked as it should. I now have Europe lifetime map V10.10.