Spark 3 GPS Fitness watch

GeertGeert
GeertGeert Registered Users Posts: 1
New Traveler
edited January 24 in TomTom Sports
I have set Dutch language to my device, but it shows Chinese charaters to the device. A reset to the device did solve this. How can I solve this problem?

Comments

  • tfarabaugh
    tfarabaugh Posts: 16,936
    Superuser
    When you go to settings in MySports (click your name in the upper right) what language is it set for? That determines the language. Where did you get the watch? There were completely separate devices for China and if you got one of them that may be the issue as well. If you press down from the clock 8 times, press right, then click right on the first entry it will take you to the language settings on the watch. The 7th entry down is Danish. If all else fails you should call Support. To get the number for Customer Support, select Contact Us at the bottom of this page, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.