MyDrive Connect tried to update and has "does not have an app associated with it for performing this — TomTom Community

MyDrive Connect tried to update and has "does not have an app associated with it for performing this

PeteGBRPeteGBR Posts: 2 [Apprentice Traveler]
edited January 2019 in MyDrive Connect
I'm on W10 home 1803 and all was functioning until the update.
Full error is:
C:\users\administrator\appdata\local\temp\tempMDC.lnk
This File does not have an app associated with it for performing this action.
Please install an app or, if one is already installed, create an association in the default apps settings page.

Does the same with Windows and Vista downloads. Something messed up.
Can anyone resolve this?

Comments

  • GerardTrompGerardTromp Posts: 21 [Master Explorer]
    I just had the same error when updating from 4.1.7.nnnn to 4.2.3.3625 (required update).

    I solved the problem by logging in as an administrator. That is, it seems the update does not play well with Access Control (where a regular user elevates the process to administrator; but is not running everything as administrator). This error suggests that a sub-process does inherit the appropriate permissions from the parent process and is being run in regular user space (ACL permissions of a regular user and not an installer process).

    If you do not have an administrator user, create one with a login and then log in as that user. Run the MyDrive Connnect as that user and wait for the update message. Once executed as an administrator, everything should be fine (worked for me).
  • Phil-MaierPhil-Maier Posts: 1 [Apprentice Seeker]
    Thank you, Gerard Tromp. Same problem, same solution. Saved me a lot of time.
This discussion has been closed.

Who's Online in this Category0