Unable to switch on my watch — TomTom Community

Unable to switch on my watch

JahvascJahvasc Posts: 3 [Apprentice Traveler]
edited January 2019 in Runner & Multi-Sport

I have switched off my tomtom runner watch following the instructions on TomTom Sports Connect. After this, the watch has not switch on anymore. I have tried to connect it to my mac, but it keeps telling me to connect the device. What motivates me to turn the watch off was that its buttons were not working anymore even after I tried to fix them with insulating tape. Does anyone know what I should do to turn the watch on?


  • tfarabaughtfarabaugh Posts: 16,681
    Plugging it in should turn it back on. Are you getting any error messages when you plug the watch in or is it being recognized at all? Does the clock face change to a battery charging icon (which indicates it is getting power so there is a partial connection). Make sure it is fully snapped into the cradle, if it does not have a full connection it will charge but it will not be recognized by the computer. It seems simple but this is generally the issue. It needs to fully click into the cradle and it may help to take it out of the band to do so. Also check that none of the pins on the dock are bent or pressed in, as that will prevent a connection.

    If nothing above helps you may have a bad dock or there may be computer setting blocking it. At that point I would suggest calling Customer Support and seeing what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, click Contact at the bottom of this page, enter the product name and click Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • JahvascJahvasc Posts: 3 [Apprentice Traveler]
    Thank you very much for your answer. I have checked the physical connections and also the software and they all seem to be ok. In any case, before I turned off the watch they were all working well. However, since I was facing problems with the pins, one or more of them may be pressed in. In this case, I don't think I have the necessary skills to fix the problem.
    I could try to call the Customer Support but I live in Brazil and it seems that it doesn't exist here. I will make a deeper search, though.
  • JahvascJahvasc Posts: 3 [Apprentice Traveler]
    Tfarabaugh, I think you were right about the pins. When I removed the button bezel (?) the watch turned on. Now I'll see if it is possible to repair the pin's contacts. Thank you very much.
Sign In or Register to comment.

Who's Online in this Category0