Can't install MyDrive Connect — TomTom Community

Can't install MyDrive Connect

FlugesFluges Posts: 1 [New Traveler]
edited October 2020 in MyDrive Connect
When I tried to install the latest version of MyDrive Connect, I can't get further than "VCRuntime140.dll not found and "MSVCP140.dll not found". My old MyDrive Connect has been deleted so now I can't update or install maps for my TOMTOM Go51.

Comments

  • Phil-the-PillPhil-the-Pill Posts: 17 [Master Explorer]
    Been trying for months now to install MyDriveConnect but the installer refuses to open! Support suggests I should try a different computer (ha ha - like we all have multiple devices). I do not have a MyDirve folder in Program Files(x86) as this is a new / clean install. So completely baffled. Given that any other app I have installed recently has no problems. What is so special about TomTom - does it require something else which is not packaged in the installer??
  • LAURE123LAURE123 Posts: 1,632
    Superuser
    edited October 2020
    Hi @Phil-the-Pill

    It would be useful to try to help you if you gave more information about your problem.
    - Do you have an error message, which one?
    - Which Windows version is installed on your PC?
    - Which TomTom device do you have?

    Some thoughts:
    I assume your PC is under Windows since you are talking about the "Program Files (x86)" folder.

    MyDrive Connect (MDC) is Not an Application (App) but a Software with an .exe installer.
    Errors like the one described above are very, very rare. The latest MDC version for W10 now installs if needed Visual C++ 2017, the installer does what is necessary without user intervention.

    If your PC is under "Windows 10 S" ("S" as Security) it can only install the Apps offered and downloaded from the "Microsoft Store". No possibility to install MDC or other software from a third party source. Either you remove "S" mode from your Windows at your own decision or you have to use another PC (maybe family, trusted friend).
    Look at this post on "Windows 10 S": https://discussions.tomtom.com/en/discussion/comment/1720975#Comment_1720975

    If you use a Home or Pro version of Windows, to install MDC you must use a PC user account with "Administrator Rights" otherwise the installation cannot be completed.
    "Restart" your PC with an administrator account, download the correct version for your PC (there are two for Windows) and retry the installation.
    Look at here: https://help.tomtom.com/hc/en-gb/articles/360013959499-Installing-MyDrive-Connect

    Otherwise give on this forum more information about your PC problem.

    Regards.
  • Phil-the-PillPhil-the-Pill Posts: 17 [Master Explorer]
    Hi @LAURE123 Thanks for your reply. To answer you questions:
    - There is no error message directly from the attempted installation
    - my OS is Windows 10 Pro 2004 - full admin rights
    - TomTom Go 1005

    The problem is as follows. I can download the installTomTomMyDriveConnect.exe and save it to my PC. However, when I run it it just does not open, even if I select to "run as administrator" which I already am! All I see is a very brief glimpse of the little rotating circle indicating something is happening, but then nothing!
    In the Event Viewer I get the following:
    Application pop-up: InstallTomTomMyDriveConnect (3).exe - Application Error : The application was unable to start correctly (0xc000007b). Click OK to close the application. Which I believe may be a reference to the C++ not being present. I can see I have the Visual C++ 2015-2019 redistributable in my program listings. Not sure if some specific *.DLL's are required to be somewhere in a folder. Any further assistance would be appreciated.
  • Phil-the-PillPhil-the-Pill Posts: 17 [Master Explorer]
    Hi Laure123, Thanks for your input and advise; unfortunately even after following all of the above it stubbornly refuses to open and install. Running all of the Microsoft repair and scanning tools does not throw up any issues on my PC and all the updates are up-to-date. If I get time I may try uninstalling all the Visual C++ X86 packages on my PC and see if MYDrive installer will pull in whatever version it requires automatically. Thanks for now.
  • LAURE123LAURE123 Posts: 1,632
    Superuser
    edited November 2020
    Hi @Phil-the-Pill

    Sorry for the late response. :disappointed:

    Have you checked that you have the NET Framwork updates? In the Windows Updates history it is in "Other updates" at the bottom. We had one in November.

    I'm not sure you need to uninstall all Visual C++, only 2015/2017/2019 which have data in common. The previous ones are autonomous (2013, 2012, etc ...). You uninstall the X86 (32 Bits) and also X64 (64 bits) versions. If MDC is partially or incorrectly installed, uninstall it as well. "Restart" your PC (not turned off)
    Install a fresh copy of MDC take it here, hope it works.
    If you must reinstall all Visual C ++, follow the annual chronological order. The X86 version first then if necessary the X64 for each year.

    I just did a test on my own W10 PC. I had 2 individual Visual CC++, one for version 2015 (x86) - 14.0.24215 and one for version 2017 (x86) - 14.14.26429. Both linked to MyDrive Connect.

    To get the same situation as you, I installed the latest package VC_redist.x86.exe Microsoft Visual C 2015-2019 Redistributable (x86) - 14.28.29325 (2015 + 2017 + 2019) taken here.

    The former independent Visual 2017 version was deleted automatically, I manually deleted the former 2015 version. Then uninstall MDC and Resart my PC.
    I installed MDC which works perfectly with this Visual C++ package containing 2015 + 2017 + 2019.

    I keep my fingers crossed that you are successful. Otherwise, you can try the rescue version I gave in my previous post.

    Regards.
Sign In or Register to comment.

Who's Online in this Category0