RIDER 400 phone call problems — TomTom Community

RIDER 400 phone call problems

raesewellraesewell Posts: 137 [Supreme Navigator]
edited January 2019 in RIDER
I have a Rider 400 connected to a Sena 20S Evo and a Samsung Galaxy S8 I have recently developed a small irritation. When I get an incoming call I don't have the Red and Green buttons on the screen, I hear the phone ring but have no way to answer the call from the Rider 400 unit. I have found a fix by getting the phone to automatically answer the call but I would like the opportunity to reject calls. I have unpaired and repaired all the devices and I have performed a Drumroll reset and performed a full factory reset.
The problem still persists. Has anyone else had this problem? If so, is there a fix?

Comments

  • raesewellraesewell Posts: 137 [Supreme Navigator]
    As an update: I have just tried it with my wifes phone Galaxy S5 which was my previous phone which worked fine in the past but now has the same problem as my S8 so the phone is ruled out as the culprit.
  • Ste7iosSte7ios Posts: 747
    Superuser
    Rider’s hands free calls are really problematic, buggy... Most of the time doesn’t work reliably.

    I decided lately not to use the feature. I paired the phone directly to the headset’s second channel to answer a call when needed. Anyway I’m using the “Do not Disturb while driving” of iOS 11 so most of the time the hands free call is unneeded...
  • raesewellraesewell Posts: 137 [Supreme Navigator]
    I agree the accepting of calls is generally not needed, I do however want the Tomtom to do what it is supposed to. So an answer or a fix would be appreciated.
    Whilst you reply is welcomed it does not answer any of my questions and as such is pretty useless to me, with all due respect.
  • Ste7iosSte7ios Posts: 747
    Superuser
    Yes, I know... We’re begging for a solution for that and other malfunctions since the Rider 400 with no response - solution three years later... Don’t waste your time. I gave up...

    Take your time to browse the forum. The same problems are repeated again and again even on newer models...
  • raesewellraesewell Posts: 137 [Supreme Navigator]
    I found that if I touch the phone icon to download the contacts (which takes about 5 or 6 minutes) once they are downloaded the red and green buttons appear and the unit gives me the opportunity to answer or reject calls, but not before.
  • Ste7iosSte7ios Posts: 747
    Superuser
    It’s necessary to wait it to finish downloading. The problem is that it’s necessary every time you power on the device. Other users with more contacts are waiting a lot more. They’re downloading the whole address book instead of syncing just the changes...

    A workaround is to limit the number of contacts that transferred by using specific groups if your phone provides that functionality...

    One more problem is the instability of the conmection. I could answer only 3 to 10 phone calls...

    Let us know how it goes...
  • raesewellraesewell Posts: 137 [Supreme Navigator]
    I'll give the Group contacts a try.
  • raesewellraesewell Posts: 137 [Supreme Navigator]
    The group contacts didn't work, I set the phone to display only Phone contacts of which there are 12 but it downloaded the whole phonebook of 127 contacts which took 5 minutes 40 seconds. I suppose I can live with this by downloading the contacts before I set off and making sure the unit stays on. This is not ideal but it is a solution.
  • Ste7iosSte7ios Posts: 747
    Superuser
    That’s not enough. You’ve to select the group you want from the Bluetooth pairing settings. I’m not sure that is supported by any Android version yet.

    On iOS I can choose phone recents, favorites and any available contacts group:

    it is like that: http://www.ilounge.com/index.php/tips/comments/managing-bluetooth-contact-sync
  • raesewellraesewell Posts: 137 [Supreme Navigator]
    You are correct, not supported by Android, so not an option for me. I can live with what I have for now.
  • NIgel_BurchNIgel_Burch Posts: 2 [Apprentice Seeker]
    I had this and loads of other phone-related problems with my Rider 400.
    BUT.
    I now have them all resolved!!
    I had taken out 3 year extended warranty and last year I could not get the unit recognised by Tomtom MyDrive on this or any other PC. I clamed under the insurance and they accepted the claim. Sent the 400 off and it came back a few days later. Same unit, same serial No., but now its a 450, so they've upped the firmware.
    Now, my phone book uploads in just a few seconds which it had never done before and all the other functions are just fine.

    How you get Tomtom to agree to update your firmware is another matter, though!
Sign In or Register to comment.

Who's Online in this Category0