Via 130 screen is blank

TomTomJan
TomTomJan Registered Users Posts: 3
Apprentice Traveler
edited December 2021 in Devices using MyDrive Connect
When I turn on my Via 130, the screen remains blank, but I hear the power on clap. The machine also talks, eg mentioning the country I am in. But nothing displays. Occasionally, after lots for messing about power on, power on, scree reappears and all is well. Then next time, when I try and use the GPS, the screen remains blank.

I've reinstalled the latest software. Tried keeping the power on button pressed to reset the device, but no success.

Can you please help?

Comments

  • dhn
    dhn Posts: 33,382
    Superuser
    Might be the battery is dying
  • Niall
    Niall Posts: 11,114
    Superuser
    @TomTomJan

    Here is a link to an equivalent device battery replacement https://www.newpower99.com/TomTom_Via_1435_Battery_Replacement_Kit_p/tomtom via 1435.htm

    UK
    "AW">Via 130 / 135, 4GB + micro-SDHC, MyDrive Connect NAV3
    US
    "AW">VIA 1430 / 1435, 4GB + micro-SDHC, MyDrive Connect
  • TomTomJan
    TomTomJan Registered Users Posts: 3
    Apprentice Traveler
    Thanks for the suggestions, but I don't think its the battery, as the screen will not light up, even when plugged in. Also the device is working, as it does give voice commands - eg "switching to UK time zone", clapping sound etc.
  • TomTomJan
    TomTomJan Registered Users Posts: 3
    Apprentice Traveler
    Have just found the answer on another forum! And it fixed it for me!!

    For anyone with same problem, you just need to open up the unit and remove and re-insert the screen connector. Looks like it had a poor connection. It works perfectly now.

    This video shows how to open up the TomTom Via 130:


    Good luck
  • dhn
    dhn Posts: 33,382
    Superuser
    Thank you for the feedback, Jan. Glad you got the situation resolved.