How to change the language on the Adventurer

Martin32Martin32 Posts: 2 [Apprentice Traveler]
edited August 14 in TomTom Adventurer
I just got a watch: TomTom adventurer. I have downloaded TomTom Sports Connect to my computer and connected my watch. I have also made a profile on TomTom's page where i have chosen my language. I can not seem to find another place to choose language than on my home page at TomTom.com
When I disconnect my watch from my computer to use it the menu is on chinese i think. How do I change this?

Comments

  • Martin32Martin32 Posts: 2 [Apprentice Traveler]
    Found it with some clicking
  • TähtimoottoriTähtimoottori Posts: 1 [Novice Seeker]
    I have same problem. how i can fix it?
  • VikramKVikramK Posts: 7,787 TomTom Moderator
    edited August 14
    Hi @Tähtimoottori

    Welcome to the community!

    When you are on the screen which shows the time

    1. Press down on the square control button and scroll down to the 8th option which is PROFILE
    2. Press right on the square control button(The first selection here is LANGUAGE)
    3. Press right again and you will see the list of available languages. Scroll(up and down) until you find ENGLISH.

    Regards
    Vikram
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
Sign In or Register to comment.

Who's Online28

MitchAir
MitchAir
SuperDad
SuperDad
+26 Guests