Update Failed on the GO 400?

ttgo400
ttgo400 Registered Users Posts: 6
Neophyte Traveler
edited January 2019 in Devices using MyDrive Connect
This is on a Go400. MyDrive Connect said I had two updates, speed cameras and map corrections, MyDrive completed ok but the device said Update Failed. I don't know which one failed and MyDrive is saying that my device is up to date.

Anyone know what I do please?

Thanks.

Comments

  • Niall
    Niall Posts: 11,115
    Superuser
    @ttgo400

    Remember after each up date to do a soft reset, you will loose nothing, it is like rebooting your computer and reloads all the new files from an update. Also might offer to re-update.

    A soft reset :- with your device charged for at least 2Hrs "OR" have the device plugged into a power supply; press and hold your on/off button until you hear a drum-roll sound (or the TomTom hands symbol appears) then release the on/off button. Make sure you are outside and have a clear view of the sky (satellites)
  • mrpj3
    mrpj3 Registered Users Posts: 132
    Outstanding Explorer
    I had similar happen last week with my 6100.
    After supposedly updating map corrections and speed camera updates the "Update Failed" message displayed with a "Try Again" option. I tapped the try again and it looked as though part of the speed camera update didn't on the first attempt. It then installed the small second part.
    For whatever reason the speed camera update, on my device, always splits into two separate parts.
    The up to date message then appeared.