Multisport frozen on the time screen — TomTom Community

Multisport frozen on the time screen

KB44KB44 Posts: 1 [New Traveler]
edited January 2019 in Runner & Multi-Sport
My multisport is frozen on the time screen. The time and date are correct but none of the buttons are responding. My computer doesn't recognize the watch when plugged in and I have tried inserting the watch into the cradle, pressing the down button then connecting it to the computer as suggested in other forums but this still doesn't work.

Any suggestions?

Comments

  • tfarabaughtfarabaugh Posts: 16,528
    Superusers
    All I can suggest is the recover y mode reset as outlines below. Please note you have to hold the button for an extended period (like 10 seconds or more):

    1. Place your watch in the dock before you connect the dock to the computer.
    2. On your watch, move DOWN but keep the button pressed.*
    3. Connect the dock to the computer. Keep pressing the button until your watch shows tomtom.com/reset.
    4. Release the button and wait for MySports Connect to show Update.
    5. Click Update in MySports Connect.
    * If the USB port on your computer is not easily accessible, connect the dock to the computer without the watch. Then move down from the clock screen while you slide the watch into the dock.

    If that does not work you should call Customer Support. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, choose Contact Us at the bottom of this page, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
Sign In or Register to comment.

Who's Online in this Category0