formatting micro SD card

Still trying to get my Via to format 16G micro SD card. Got card to format FAT32 on my computer, but still no joy when installed in Via. Does the 'allocation unit size' matter?

Comments

  • NiallNiall Posts: 10,552 Superuser
    Help others identify useful content :- - If someone posted something that was helpful? Click the Like button 👍

    If someone answered the question you asked? Answer Yes to "Did this answer the question? Yes · No"
  • kadiddlehopperkadiddlehopper Posts: 6 [Apprentice Traveler]
    After successful format in Windows, formatting in the Via runs a few minutes then re-boots. After re-boot, same "memory card needs formatting" comes up. Answering yes results in endless formatting attempt, same as when I first inserted the card. Still wondering if 'allocation unit size' when formatting on computer has anything to do with it?
  • dhndhn Posts: 33,188 Superusers
    What brand sd card? Some don't work well with TT units.
  • kadiddlehopperkadiddlehopper Posts: 6 [Apprentice Traveler]
    ADATA micro SDHC, 16GB class 4
  • dhndhn Posts: 33,188 Superusers
    Too slow. You should use a class 10 card. Use a SanDisk 16 gb card.
  • aterhaaraterhaar Posts: 1 [New Seeker]
    Hi @dhn,

    I'm struggling already for 2 months to get a new EU card installed on my TomTom GO 510, but due to its size (8GB), I needed to install an SD card on my device, which meanwhile I did.

    However, I'm now experiencing the exact same issue like @kadiddlehopper, having tried numerous times to format a Kingston 16GB MicroSD card (Class-10), but each time it aborts after around 20 seconds with following error:

    "Formatting Error - The memory card could not be formatted, It cannot be used on this device."

    Interesting fact, based on an experiment I did:

    - I successfully managed to format a SanDisk 2GB MicroSD card and get it recognized by my device.

    So there are 2 differences between both MicroSD's; the SD card size and its brand ...

    I can't imagine, though, that TomTom would be so exclusive in accepting inserted MicroSD cards ...

    Pls, advice, if possible, before I spend another amount of EUR 10.= on a new 16GB MicroSD card. Thanks.

    Cheers,
    André.
  • DougLapDougLap Posts: 2,813 Superuser
    Hi @aterhaar

    Could you try Reformatting your Kingston Card on your PC. Format it for Fat32 and do a full Format not a Quick Format. Then reinsert it in the TT unit and see if it will now format there.

    Doug
  • YamFazManYamFazMan Posts: 14,799 Superusers
    edited August 14
    Hi
    @aterhaar

    Be Aware...
    Maybe You have a Counterfeit Micro SD Card ???
    There are lots of Videos online... How to identify a FAKE Micro SD Memory Card
    Just Google 'Counterfeit Micro SD Cards'

    I downloaded the Micro SD Card Test Program 'H2testw' from Softpedia
    It generates and copies 1GB files to the card until the card is full + Checks the Read/Write speed

    Note... The program 'H2testw' checked out as Virus free... Using Avast AV & Malwarebytes

    https://www.softpedia.com/get/System/System-Miscellaneous/H2testw.shtml

    Luckily all my cards check out OK

    Use the above at your own discretion...

    ATB YFM
    Help others identify useful content...
    If someone posted something that was helpful?
    Click the 'Like' > 👍 Icon
    ____________________________

    If someone answered your question?
    Please answer 'Yes' to Did this answer the question? 'Yes' < >' No'
    ____________________________
Sign In or Register to comment.

Who's Online10

Naftali
Naftali
royhum
royhum
+8 Guests