TomTom Runner 3 Display Language — TomTom Community

TomTom Runner 3 Display Language

aconsta385aconsta385 Posts: 2 [Apprentice Traveler]
edited January 2019 in Runner & Multi-Sport
Trying to pair my watch to my smart phone, but my watch's display language is still in Chinese, even after updating and syncing online with my computer; would anyone please assist me in changing my watch's display language from Chinese to US English? Thank you, in advance!

Comments

  • tfarabaughtfarabaugh Posts: 16,683
    Superusers
    Press down from the clock, go to the 8th menu item, press right, go to the first menu item, press right, go tot eh first menu item and press right. That will turn it back to English. Also go into your Settings in MySports and check what the default language is there as that will override any changes made to the watch itself.

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • aconsta385aconsta385 Posts: 2 [Apprentice Traveler]
    Thank you very much... good to go!!!
Sign In or Register to comment.

Who's Online in this Category0