Spark 3 - No connection with USB and Bluetooth pairing

SvenDev Registered Users Posts: 4
Neophyte Traveler
edited January 24 in TomTom Sports
I have a spark 3 with the 1.7.62 firmware on it. As the bluetooth connexion, to upload my running data, didn't worked, I decided to upload it directly through My Sports on my laptop (with USB). The application starts and shows during a short moment that it is connected, but then it says "we are unable to make a connexion with your watch".

I do get the charging symbol on my watch.

I tried soft and hard reset, but the hard reset doesn't work (no reset).

I then decided to remove the app from my laptop and to re-install it. This still didn't worked.

Now I have a watch, but can't upload any running data (and my watch memory will be full at a moment), I can't get the quick GPS, can't upload new songlists, etc.

I hope someone can help me to get it working again!!



  • tfarabaugh
    tfarabaugh Posts: 16,973
    Make sure the watch is fully snapped into the cradle. If it does not have a full connection it will charge but it will not be recognized by the computer. It seems simple but this is generally the issue. It needs to fully click into the cradle and it may help to take it out of the band to do so. Also check that none of the pins on the dock are bent or pressed in, as that will prevent a connection.

    You cannot connect to the app on your phone because of the 1.7.62 update. You can request a rollback using this link:

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • SvenDev
    SvenDev Registered Users Posts: 4
    Neophyte Traveler
    Thanks for the tips. I checked the connexion to the cradle and everything looks good. I know that my battery was completely empty before the problem happened. Would formatting the watch help? If so, how to get the firmware back on it?

    In the meantime I asked for a rollback so that I can connect it to my phone.

  • paulpay
    paulpay Registered Users Posts: 10
    Apprentice Seeker
    @SvenDev I have a similar problem with the PC, and one of the data connection dots on the reverse of my Spark Music+Cardio is damaged, there is no "gold" of the connector left. I have to really struggle to force a connection to the pc. See if yours also has this damage.
  • SvenDev
    SvenDev Registered Users Posts: 4
    Neophyte Traveler
    @paulpay I checked the connectors and they all look to be in a very good shape, still covered with the "gold/copper" plating... :-(