RUNNER 2-Oops, something has gone wrong when updating firmware

skee81
skee81 Registered Users Posts: 4
Apprentice Traveler
edited January 24 in TomTom Sports
I have a TomTom Runner 2 with software version 1.3.255
It connects to both PC and phone without problem and does synchronize.
Yet, there is update of watch software since Dec 2017, to newer version 1.7.62
The memory of the watch is empty. I tried resetting it from the software, that gives the same result, so I can't even reset.
PC runs Windows 7 64bit SP1.
Any idea/help welcome.

Comments

  • tfarabaugh
    tfarabaugh Posts: 16,935
    Superuser
    You do not want the 1.7.62 update as it breaks connectivity with the phone. I believe they have actually pulled it which is why you are not getting a prompt to update. Just wait until the next release which hopefully will fix the connectivity issues.

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • skee81
    skee81 Registered Users Posts: 4
    Apprentice Traveler
    Many thanks tfarabaugh! Well, it is not solving, but indeed I have to agree, there is nothing wrong wit the current firmware, so if the update is not worth it, better stay as is.
    thanks!