tomtom.com Reset password button not working — TomTom Community

tomtom.com Reset password button not working

fatlofatlo Posts: 10 [Legendary Explorer]
edited January 2019 in Travel lounge
I was wondering: does anybody else have trouble requesting a new password when using Chrome or Firefox? Asking for a new password only worked with Internet Explorer for me. In the other browsers, the SEND button had no effect ...

Comments

  • VikramKVikramK Posts: 12,678 Moderator
    Hi fatlo

    Welcome to the community:)

    I just tried this and it seems to be working for me both Google Chrome and Firefox.

    Could you clear the browser cache and try again?

    Regards
    Vikram
  • fatlofatlo Posts: 10 [Legendary Explorer]
    Hello Vikram,

    thanks for your reply. Clearing the cache may have done the trick ... although I am not sure.

    The problems may be related to the fact that I use a VPN to access the site and that my connection is slow.

    However, I wonder why the main site has to be so picky while this forum works (an always worked) perfectly. Does not look like robust programming to me.

    Regards,
    Olaf
  • fatlofatlo Posts: 10 [Legendary Explorer]
    Update: today, the buttons refuse to work again with Chrome. I have to use EDGE or IE to make it work. Maybe the site is using some Google components which are blocked because Google does not like our VPN ...
Sign In or Register to comment.

Who's Online in this Category0