Golfer Watch — TomTom Community

Golfer Watch

johnnymallenjohnnymallen Posts: 7 [Master Explorer]
edited January 2019 in Golfer & Golfer 2
Golfer watch won't get past "There has been a problem...". Just goes round in a loop. Wont connect to iPhone either. Now just stuck on the time and as such is now useless apart from telling the time.

Comments

  • ronnykapteinronnykaptein Posts: 18 [Outstanding Explorer]
    Hi Johnny

    I managed to get a work around for the following TT golf watch issues;

    1)Memory Full/Storage Low
    2)GPSfix not updating


    I tested my work around twice and it seems to be working fine for the issues above.

    All you do is plug watch into dock while connected to computer.
    *Do a factory reset from app
    *Follow steps up to "Updating Golf Courses"
    *Select "Updating Golf courses"
    *40 minutes into update, unplug watch from dock irrespective of updates completed or not.

    The watch will have reverted you back to your last round and the low storage and gpsfix will be resolved. However you will still receive error message on computer app to fix or to reset watch which you can ignore until TT release update for fix.

    As i said this is a temp solution which enables you to use your watch on the golf course at least while waiting for TT.

    Regards
    Ron
  • LabadieLabadie Posts: 8 [Legendary Explorer]
    This is what it keeps coming back to. I've played 1 round of golf. I connected to the OSX (mac mini 2012) but it keeps looping back to the error message. I've tried both reset and fix it multiple times but this is very annoying. I got the watch as a present from a golf buddy I'm playing again with on Friday and I'd like to wear and use the watch. I don't know what to do...

    Because I don't have the issues mentioned by Ron I havent tried to unplug it during update (and I don't want to brick the watch)

    Suggestions are welcome

    65954e26-3171-4424-a540-cebef88beed4.pnga6ca7e76-70ec-4e78-90e4-bf8afa7fd359.png
  • ronnykapteinronnykaptein Posts: 18 [Outstanding Explorer]
    Hi Labadi


    There's nothing you can do. This is a general problem with TT that must be resolved.

    None of us can update at the moment and please dont otherwise you will have the same issues that all of us have.

    Regards
    Ronnu
  • johnnymallenjohnnymallen Posts: 7 [Master Explorer]
    Hi Ronny,

    Thanks for that. Sadly it didn't work on mine.If I unplug it early it won't move from a screen telling me to plug it back in.

    Thanks

    Johnny
  • ronnykapteinronnykaptein Posts: 18 [Outstanding Explorer]
    Hi Johnny

    You have to let it update pass the halfway mark before you unplug it. In others words let it update for more than an hour but a better gauge to use is to let the update go pass the halfway mark.

    It works, trust me but let me know once you tried above if it worked.

    Regards
    Ronny
  • johnnymallenjohnnymallen Posts: 7 [Master Explorer]
    It just sticks on a screen with an icon of a computer and another of the watch. It won't move from there.
Sign In or Register to comment.

Who's Online in this Category0