Updating TomTom GO 500/510

IA88 Registered Users Posts: 2
Apprentice Traveler
edited January 2019 in MyDrive Connect
Help! I cannot get my computer to recognise my TomTom GO 500/510 to do updates. I have previously used this machine with this TomTom to update without problem. Here is what I have tried...

Switching computer on and off :)
Fully charged device, switched on before opening MyDrive Connect
Fully charged device, switch on after opening MyDrive Connect
Both of the above with each of my 3 USB ports
Both of the above with the TomTom cable and with another USB cable in case that is the problem
Turning off Firewall and anti-virus and repeating the above

This suggested by Zsolt on the forum about a year ago
"Click on the Start button and go to All Programs › TomTom › Uninstall TomTom MyDrive
Remove the application file:
Press the Windows logo key +R to open the Windows Run dialog
Type %localappdata%. Click OK.
You will see list of folder. Find and open TomTom folder
Delete HOME 3 folder.
Delete the MyDrive Connect folder from: C:\Program Files (x86) (if still present)
Delete the TomTom folder from: C:\Users\[username]\AppData\Local\ (USERNAME - It is the user name which you use to login to Windows )
Delete the TomTom folder from: C:\Users\[username]\AppData\Roaming\
Delete every file and folder from: C:\Windows\Temp\ (in case some files can't be removed, reboot the PC and retry)
Restart your computer

Re download a new installer from http://www.tomtom.com/mydrive (I recommend you to use the Google Chrome while downloading the installer)

Now install MyDrive Connect with the newly downloaded installer.

After the installation process of the new MyDrive application completes successfully, please restart your computer. Now, check if the application is able to connect to your device properly or not."

When I look into device manager there is no sign of the TomTom Go Live.
I am running Windows 10.


  • IA88
    IA88 Registered Users Posts: 2
    Apprentice Traveler
    Thanks. Should have said, that was first point of call for steps to resolve

    I also did a complete reset of the device and tried all USB ports. The only step here I couldn't do was to uninstall the driver because it simply doesn't show up. Perhaps that's the issue?

    I tried this on my own laptop which I have previously used to update the Tom Tom, and also on a desktop computer with a clean install of MyDrive Connect, also on Windows 10. No luck there either.
  • dhn
    dhn Posts: 33,393
    And you are using the cable that came with the device? I guess a call to support is in order: (not 1/1/2018, though)

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • Pilcher9
    Pilcher9 Registered Users Posts: 1
    Apprentice Traveler
    I had similar problems truing to update a Europe map prior to our visit in a few weeks. I initially had Australia and New Zealand installed on the Device itself. I also had Europe and North America installed on the SD card.
    When I logged on th update it said I had 5 updates waiting. So we started the process. After some time it failed, saying something like "Sorry, so items did not load properly"
    So I started again. This time I only had 1 update available. it fell over again. it would appear that a map download to the computer was successful, but the install failed. Next thing My device said no maps were available. I was able to successfully load the small Australia and New Zealand maps, but the huge Europe and America files were the problem.
    I contacted support and they claimed there was a problem with my Internet service and I should try on other computers. I cant really see that as my computer indicates that the download worked
    So I tried again
    I initially tried on my desktop computer with a direct Ethernet connection to the modem.
    I tried uninstalling MyDrive connect, and reinstalling, to no avail
    I very reluctantly disabled my Firewall and Anti virus, but again I got the same result
    I then tried using my nearly new laptop with a WIFI connection (it has no Ethernet port)
    I tried using a different internet connection in a different house and a different ISP
    I tried yet again in a different House, ISP computer with Ethernet connection
    In each case it would seem from the dialog on the screen that the file download to the computer was successful. Then the map update or load to the device commenced. It would get to somewhere between 6 and 10 percent completed, the display indicated a lesser completion state. It would toggle between 5 and 8 percent for a couple of minutes, then in the next instant it was 100% and finishing. Then a message to say Sorry some items did not load properly.
    This was the same in every attempt.
    In desperation, I purchased a new SD card, and the process worked
    I don't know why this happened. On my old SD card I had Europe and America loaded. When I first commenced this update process the opening screen said I had 5 updates available. After I commenced the process, the first of these fails appeared. The next time it said I had no maps installed, not even Australia and New Zealand on the device.
    I can only assume the initial process corrupted my SD card, causing further downloads to fail.
    I am sorry this is so Long winded, but I guess it provides a measure of my frustration. But the short answer is that a new SD card appears to have solved my problem. (for now).
  • Milkybarkid
    Milkybarkid Registered Users Posts: 6
    Master Traveler
    My last Tomtom was the Go520. I left taking advantage of an update for too long (price usually fell) and they knocked me out saying no more updates. The updates would take 20 minutes at the most for a new map.

    First update on the new Tomtom 50 took a bit of time but not as long as this latest one which they suggested I needed. Started at 11 on Sunday morning and at 11 in the evening it had only reached 90%. Only saving grace is that it carried on this morning.

    This is absolutely barmy, crap service and no wonder they are losing business because of new cars that have them ready installed. This is so crap that I am tempted to get a Garmin. Getting lost is one thing but making people wait for downloads really will send them elsewhere.

    I would assume they've given up reading all the download complaints or they would have done something about it before.
  • Spycam
    Spycam Registered Users Posts: 4
    Master Traveler
    I have had previous Tom Tom models now have the GO 500/510, everything ws fine except for the fact that most times i get the battery low message even when its using the original cable and connected into the Lighter socket as always.
    BUT now i started having issues connecting to MY DRIVE, start app up connect the device and always on 3 different computers said not connected, i tried a fourth and was successful but problem is that was not my computer so im still stuck with the issue of not able to connect,
    Yes its the original cable.
    Yes its Windows 10
    Yes its updated correctly
    Did a quick google search and amazed to find thousands of hits of people having this very same issue! And more amazingly not one correct solution from tom tom for us anywhere that i can find, the ones i saw i followed and did not help in the least.
    Finally in frustration i called Tom Tom Support and since my units out of warranty was told they can not do anything except offer me a discount on a new unit!! No not 10% but they willing to give me a whopping 30 % off!
    i Laughed at him and said you want me to go out and spend more money and buy another device when i have one already?And you just cant find the solution to a serious issue with your units which so many seem to be having?
    Never again will i buy a tom tom unit EVER not after this sort of crappy service.
  • Spycam
    Spycam Registered Users Posts: 4
    Master Traveler
    YES i tried all of those
    MULTIPLE reinstalling that damn stupid app, deleting the drivers etc etc etc
    And all a load of horse sh&it
    Thats why in disgust i called them and was palmed off to buy a new unit!