Windows don't read TomTom USB — TomTom Community

Windows don't read TomTom USB

takis1966takis1966 Posts: 7 [Master Traveler]
I have tomtom2 sportwatch. I bought it about 10 months ago. These days and very often after practise when i connect it to my laptop ...instead of connecting to the internet and display the data...i have the indication "windows dont recognize the usb... How can i solve this problem???

Comments

  • tfarabaughtfarabaugh Posts: 16,527
    Superusers
    Does the clock face change to a battery charging icon (which indicates it is getting power so there is a partial connection). A few things to look at (and I apologize if some are very basic but it is best to get past the obvious issues first):

    1) Are you plugged directly into the machine and not a hub?
    2) Does the port work, can the computer detect other devices (like flash drives) in that port?
    3) Is the watch firmly snapped into the cradle and the USB plug firmly in the port?
    4) Is the USB plug free of any debris or blockages?
    5) Is the Connect software actually running (is there an icon for it in the notification area)?
    6) Did you install MySports Connect, not MyDrive Connect? It is downloaded from tomtom.com/123
    7) Do you have administrator rights to the computer?
    8) Is a firewall or antivirus running that is blocking the software from connecting to TomTom (try turning them off before docking the watch)?
    9) Does the computer have a good Internet connection (Internet is required to sync)?
    10) Can you try installing it on a different machine to determine if it is an issue with the computer versus the watch?

    In particular, make sure it is fully snapped into the cradle. If it does not have a full connection it will charge but it will not be recognized by the computer. It seems simple but this is generally the issue. It needs to fully click into the cradle and it may help to take it out of the band to do so. Also check that none of the pins on the dock are bent or pressed in, as that will prevent a connection.

    If nothing above helps you may have a bad dock or there may be computer setting blocking it. At that point I would suggest calling Customer Support and seeing what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to tomtom.com/support, choose Contact, enter the product name and click Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • takis1966takis1966 Posts: 7 [Master Traveler]
    Thanks a lot my friend tfarabaugh for spending time to answer to my problem. my tomtom runner2 is charging all right. the problem is what i mentioned in my question ...the problem remains , so, from all the interesting things you mentioned i only keep the CUSTOMERS SUPPORT call. I sent them an e-mail 2 days ago mentioning my problem and i am waiting for their help.
    Again thanks a lot
    takis1966 Athens
  • tfarabaughtfarabaugh Posts: 16,527
    Superusers
    Your question said that "windows dont recognize the usb" and these are all the obvious reasons Windows may not recognize it. There may be issues with a bad driver that will require a deeper technical dive with Customer Support. You will get nowhere emailing them, take a direct approach and call them. Emails can be lost, ignored or sit in a queue for weeks (particularly around the holidays).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • takis1966takis1966 Posts: 7 [Master Traveler]
    Dear tfarabaugh i am really very sorry for my delay to thank you for your interest to my problem. I really thank you. Tomtom support contacted me via e-mail after a few days and they were really helpfull like you were to me.
    Finally, the solution to my problem was : "- wipe the gold contacts on the back of the watch and then re insert into the dock".
    I did so and everything is fine again.
    I really thank you again for the interest and i appologize for my delay to write back to you!
  • tfarabaughtfarabaugh Posts: 16,527
    Superusers
    takis1966 wrote:
    Dear tfarabaugh i am really very sorry for my delay to thank you for your interest to my problem. I really thank you. Tomtom support contacted me via e-mail after a few days and they were really helpfull like you were to me.
    Finally, the solution to my problem was : "- wipe the gold contacts on the back of the watch and then re insert into the dock".
    I did so and everything is fine again.
    I really thank you again for the interest and i appologize for my delay to write back to you!
    Glad I could help. When you get a chance please mark my response as a solution so others with the same question can look for it.
Sign In or Register to comment.

Who's Online in this Category0