Cannot start app - storage is full or not accessible — TomTom Community

Cannot start app - storage is full or not accessible

user1234567user1234567 Posts: 10 [Apprentice Traveler]
Last week I needed to free up storage on my phone (Experia XZs). I saw that TomTom Go was taking up 5GB of storage or cache on the internal storage. I decided to remove and reinstall. After resetting Spotify as well, I have 11GB free space on the internal disk, and I have 80GB space on the external SD card. Up til then TT Go worked normally.

After reinstalling, I got the following message. NB: this is a translation from Dutch, so it will probably be worded differently!

Cannot start app. The storage on your phone is full or unavailable. Check the storage of your phone or your SD card. If you still cannot start the app, you need to reset it and download the cards once again.

(In Dutch) Kan app niet starten. De opslagruimte op je telefoon is vol of niet beschikbaar. Controleer de opslagruimte van je telefoon of je SD-kaart. Als je app nog steeds niet kunt starten, dien je deze te resetten en je kaarten opnieuw te downloaden.

In the past I've had problems with this phone, as it couldn't use the external SD, or only a few apps (like Total Commander) could read to and write from the SD card. The rest - like TomTom GO - couldn't use it, so had to rely on the internal storage. Several months ago I got a system update, and now that works. I don't know if that has anything to do with it, I just mention it here.

I've tried several restarts, and several reinstalls.

What can I do to get this working again?

40abab7f-0377-4a34-84a1-a00922cfaf5b.png

Comments

  • RGM71RGM71 Posts: 377 [Supreme Trailblazer]
    What you still can try to do is uninstall the app, then check if there are any maps called com.tomtom.gplay.navapp left over in both the internal and external memory of your phone (you can find them in .../Android/data/). If so, delete them (all).

    Then install the app again and check if it is working now. If not, go to the App management section in your phone settings and search for the GO Mobile app. Open it, and clear the cache an do a 'Forced stop'. After that, leave the App management section and start the GO Mobile app again to check if it is working now.

    This is not a guaranteed method of fixing your issue, but I think it's worth to try it.
  • YembleYemble Posts: 42 [Outstanding Wayfarer]
    IF you are running Android 7 and IF your extSD is set for portable storage, then you could try enabling the following Android System Setting, within the Developer Options (near the bottom of the list)...

    Force allow apps on external

    This allows write access to the extSD for any app and to any folder. Whether, or not, this solves your TT installation issue, I do not know, however, this option does solve a multitude of extSD access issues. I use this setting to allow custom map folders in AlpineQuest and OSMAND+, however, I prefer to run TT from device memory, with a smaller map (UK).
  • user1234567user1234567 Posts: 10 [Apprentice Traveler]
    After removing the app, the com.tomtom folder in Android/data is gone in both internal and external storage.

    I got it working by shutting down, removing the external SD, then install, then restart with the SD. This results in installation on internal storage.
Sign In or Register to comment.

Who's Online in this Category0