Firmware 1.7.60's Bluetooth stack is still extremely broken :-( — TomTom Community

Firmware 1.7.60's Bluetooth stack is still extremely broken :-(

WizardlingWizardling Posts: 35 [Master Traveler]
I just installed 1.7.60. It's Bluetooth stack is still extremely broken. It cannot even successfully re-pair my Spark 3 (the past two broken versions could at least manage that much, after multiple tries) with the Sports iOS app on my iPod touch 6th gen, much less reach the point of syncing :-(

Comments

  • WizardlingWizardling Posts: 35 [Master Traveler]
    So, phone support had me reset my Spark 3 to factory. This amusingly actually seemed to make the broken supposedly old 'working version' of the Bluetooth stack in v1.7.60 even more broken. Instead of attempting for a few seconds to try and pair, flicking for a moment to the pairing code, and then failing and flicking back to the main menu; now after a factory reset the Bluetooth stack fails instantly, flicking from pairing right back to the main menu, in half a second.

    Where was the testing of either of the past three firmware versions? I'm not even on Android with its myriad hardware and software configurations. I'm on iOS at the latest version of the latest hardware for my particular iOS device. How can testing fail to reveal these Bluetooth issues?!? I am at a loss to comprehend this failure. And I've witnessed some pretty poor testing and development in my time.
  • WizardlingWizardling Posts: 35 [Master Traveler]
    Also, why was this thread moved from the more appropriate watch forum? I wasn't even initially asking a question! :-(
  • Michael ProcterMichael Procter Posts: 35 [Master Traveler]
    They did tell you to delete the watch from Bluetooth settings on your iPhone didn’t they?
  • WizardlingWizardling Posts: 35 [Master Traveler]
    They did tell you to delete the watch from Bluetooth settings on your iPhone didn’t they?

    You know, they actually did suggest that in troubleshooting the two previous firmware versions. But it never made a difference one way or the other. This time, it didn't even occur to me as it wasn't a factor in affecting the outcome of re-pairing with the mobile app earlier on. And support didn't suggest it again with the latest firmware.

    But it turns out that this time it was a factor, ha! And I now have working pairing with the app and syncing again. Hurrah.

    It would probably be a good idea if the TomTom mobile app or watch handled an instance of being 'blocked' by a prior Bluetooth device pairing a bit better, if only by suggesting to the user that they try unpairing and repairing at the OS level, not just the app level. And it would have been nice to have avoiding wiping my watch yesterday, erk.

    But I guess, in the context of the far greater issues of having a broken Bluetooth stack for two months, that is just nitpicking, and I should be happy there was a way to get pairing with the app and syncing working again.

    That's for prompting me to try this step again, Michael.
  • WizardlingWizardling Posts: 35 [Master Traveler]
    Wow. My first sync via Bluetooth of a freestyle workout around a local walkway, and it took about eight minutes :-( Something is still very wrong here. I mean it worked, but eight minutes? :-(
  • WizardlingWizardling Posts: 35 [Master Traveler]
    So mods - this is no longer solved. Or not solved in terms of nothing being substantially wrong.
  • WizardlingWizardling Posts: 35 [Master Traveler]
    10m 16s to sync tonight :-D And TomTom support had the gall today to call my issue "fixed".
  • BasinXBasinX Posts: 2 [Apprentice Traveler]
    Thanks for reminding to reset after newest update, it worked. 1st sync was slow but seems be be faster now.

    Thanks
  • WizardlingWizardling Posts: 35 [Master Traveler]
    Every Bluetooth sync here still takes eight to ten minutes.
  • buduelbuduel Posts: 6 [Master Traveler]
    I updated to 1.7.60 and it still won't pair. Yes, I unpaired it first from Bluetooth settings and performed a reset. No dice.
Sign In or Register to comment.

Who's Online in this Category0