TomTom Adventurer white screen (of death?) — TomTom Community

TomTom Adventurer white screen (of death?)

proct1srproct1sr Posts: 1 [New Traveler]
edited January 2019 in TomTom Adventurer
Hi y'all,

Was gifted a TomTom Adventurer in August which I've primarily used for running (25-50 miles per week usually.) The other day I was out for a run and for 8ish miles the watch was fine. I then glanced down at it and released it had shut down/reset and when I tried to re-initiate a new run, it froze on the "GET GOING!" dialogue. After I got back I plugged it in for a soft reset and then started a new run, where it promptly froze again. From there, I did a factory reset and tried again. No luck. I tried it once last time and now it'll show the battery charging symbol when plugged in but as soon as I take it off the dock and try to navigate to anything, the screen goes white and I have to reset it again.

Anyone else had this issue? I've reset the watch every way TomTom recommends in the FAQ/support section, but no dice. Pretty upsetting if it died in less than three months of standard use.

Comments

  • tfarabaughtfarabaugh Posts: 16,812
    Superusers
    At this point I would suggest calling Customer Support to see what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to tomtom.com/support, choose Contact at the bottom, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
Sign In or Register to comment.

Who's Online in this Category0