TomTom Sport for Android no pin entry - fails to connect infinitely

Rod WhiteRod White Posts: 10 [Legendary Explorer]
Setup : Samsung S5 very latest OS (i checked OTA) Android 6.0.1 : Adventurer Version 1.7.53 (latest firmware). Android Sports App 9.0.2 Build 530

My phone is listed as "Fully compatible" in the https://docs.google.com/spreadsheets/d/1i8wFljwzFKIdFMKZX_d2sRJV8x37kIq1sHz3103YKMQ/pubhtml

Problem : When bluetooth connecting using app, watch is displayed when "searching for your device". When I click on the coloured square labeled TomTomGPS Watch, the watch provides a six digit pin and then after 5 or so seconds returns to the SETTINGS menu while the phone does one of either two things 1) stays in the "connecting" state forever or 2) moves to the "Software up to date?" screen and starts the loop again.

In the background any existing bluetooth connection (say to a car audio) will be dropped and the phones bluetooth settings will show the watch as a paired device however the watch does not show the phone as a connected device.

During this process, there is no opportunity to enter the pin and there is no notification on the phone.

I have tried everything and this loop is very frustrating.

1) i have unpaired the watch from the phone in the phones bluetooth and stopped the phone from scanning and auto-connecting to the watch.
2) I have made sure that I connect the phone to the watch in the Sports App and not the phones bluetooth.
3) I have cleared the bluetooth cache
4) I have downloaded and re-downloaded the sports app several times
5) I reset the watch to factory settings, downloading the latest firmware.
6) I have read countless forum entries over this issue and have done everything they recommend (see above)
7) I have connected the watch to an Iphone successfully

It is very concerning that this Android connection issue covers many YEARS of forum entries.

I need this watch to connect to my phone as I run to work and during that 1.5 hours I need the watch to advise me of my phone (which is in a camelback).

From my experience in IT is appears to me that this is a software issue on the APP side rather than a bluetooth protocol issue on the phone side.

This is very frustrating because my phone says it is up to date, the Sports App is up to date and the Watch firmware is up to date so there is nothing software related that I can do. In my opinion the Adventurer watch/TomTom Apps is FAULTY straight out of the box and TomTom should address these connection issues as a matter of highest priority.

Comments

Sign In or Register to comment.

Who's Online41

Bembo
Bembo
Carminat
Carminat
CB1100EX
CB1100EX
GoldiTx
GoldiTx
Lochfrass
Lochfrass
ploum115
ploum115
TrevJ
TrevJ
+34 Guests