Update problem VIA62 MyDrive Connect - waiting for device

I am unable to update my device as it just says "waiting for your device" and then gives up.

I have a VIA 62 connected to MyDrive Connect on a Windows 10 PC. Application version on the device is 17.200.0011.311.

I have done the following to try and resolve the issue:
- reset the device by holding down the power button;
- uninstall and reinstall MyDrive Connect;
- delete the 'cache' folder contents under my user profile on the PC;
- reinstall the driver for the network device on the PC;
- leave it running as long as possible, restart the PC, disconnect and reconnect the device.

Please can someone suggest some alternative methods to fix this?

Thanks, Daniel.

Comments

  • dhndhn Posts: 32,866 [Superusers]
    See what support can suggest:
    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • YamFazManYamFazMan Posts: 13,151 [Superusers]
    Hi
    Firstly Try....
    With MyDrive Connect running, your device plugged in and turned on
    Right Click Widows10 Start button
    Click Control Panel
    Click Devices and Printers
    Right Click on the Tomtom Icon and select “Troubleshoot”
    Note... Maybe listed as a Remote NDIS Compatible Device
    Follow on-screen instructions
    _____________________________________

    Manually install Tomtom Drivers
    If Windows is unable to locate the driver or Device Manager shows an error coder 28
    Plug your Tomtom into the USB port and turn it on (device needs to be connected for the divers to show in Device Manager)
    Click Start
    Right-click My Computer (or Computer)
    Click Manage.
    In the Computer Management window, on the left, click Device Manager.
    Click on Network Adapter
    Click the + sign in front of the device category for which you wish to install the driver
    Note... If there is a yellow question mark the driver is definitely missing or corrupt
    Right click on TomTom

    Note... On my system, it can be Tomtom, Tomtom #2, #3, #4 etc...I own several Tomtom devices
    Note... On my Win10 PC, its listed as Remote NDIS Compatible Device #2, #3, #4 etc...

    Right-click the device, and select Update Driver. The Hardware Update Wizard opens.
    For using Windows Update, select No, not this time and click Next.
    Select Install from a list or specific location (Advanced), and click Next.
    In the window for search and installation options, select Search for the best driver in these locations, and select the Include this location in the search checkbox.
    Click Browse, and navigate to the folder that contains the driver files.
    ____________________

    MyDriveConnect installs the Tomtom Driver files here.....
    C:\Program Files\MyDrive Connect\Driver
    Folder... INF
    Folder... win32
    Folder... x64
    _____________________

    Click OK when the appropriate folder is selected.
    Back in the Hardware Update Wizard, click Next
    Windows will search for the driver and install it automatically
    When the installation is complete, click Finish

    ATB YFM
  • PleiadesPleiades Posts: 4 [Neophyte Traveler]
    @dhn - Thank you, I'll resort to this if the other suggestion doesn't work. D
  • PleiadesPleiades Posts: 4 [Neophyte Traveler]
    @YamFazMan - Thanks for your suggestions.

    1. Troubleshoot Remote NDIS Compatible Device:
    I did this as described, and the result was this message: "Remote NDIS Compatible Device is an older USB device and might not work with USB 3.0" Two problems with this result: (a) I got the same message when I plugged the TomTom into a USB 2 port; (b) I have been updating the TomTom successfully on the USB 3 port for several months. Anyway, nothing else was reported or changed by the troubleshooter.

    2. Manually install TomTom drivers:
    I was going to do this... but found another solution along the way. I usually log in with a 'limited' user account on Windows i.e. not admin. In order to change the drivers I logged in to the admin account... and decided to try the TomTom update from there. It worked.

    I have also deleted the TomTom folder (under AppData) in the user account that was not working. I have successfully updated the TomTom (Mapshare info) on this limited account just now.

    Therefore the solution in this case seemed to be either (a) logging in as admin, rather than limited user, or (b) deleting the folder 'c:\ ... \AppData\Local\TomTom' and subfolders so that MyDrive Connect would rebuild the user's folder structure. I can't tell which of the two changes has solved the issue.

    The only other factor that was different was that, as well as updating the Map and Mapshare, the device was doing an Application update from 17.200.0011.311 to 17.300.0018.311 - perhaps this is what created a problem on this occasion.

    Thanks again for your help.
    Daniel
  • YamFazManYamFazMan Posts: 13,151 [Superusers]
    Hi
    See... if there are any Driver updates for the USB3 Ports
    Some USB3 ports are less USB2 back compatible than others
    ___________________________

    I always run MyDrive Connect as an Administrator
    ____________________________

    I agree, on the rare occasions that I have problems with MyDrive connect, I delete the "HOME3" folder in MyDrive Connect...
    If you have installed MyDrive Connect to the default location using Windows 10
    It's located here... C:\Users\"Your Computers Name goes here"\AppData\Local\TomTom > HOME3
    This removes the Cache, Prefs.ini, cookies.ini. Logs and Configuration.xml
    A new Home3 Folder and its contents are created fresh the next time you use MyDrive Connect
    ___________________________

    Method…..
    1. Disconnecting the SatNav from the PC and resetting it by holding down the off button for 20 secs until you hear the ‘drumbeat’ release the button
    2. Opening ‘Run’ on the PC (click on the windows symbol bottom left – type ‘run’ in the search box – open ‘run’.
    3, type into the ‘run’ box %localappdata% and press enter.
    4. Find the TOMTOM folder in the window that will have now opened and open it.
    5. Delete the Home3 file that is most likely corrupted and close all windows.
    6. Turn on the SatNav and reconnect it to the PC and open ‘My Drive Connect’ and all should be well

    ATB YFM
  • PleiadesPleiades Posts: 4 [Neophyte Traveler]
    Thank you YamFazMan for your help and suggestions. Most of the time the updates go through without a problem, even using USB3 and a limited user account; I'll take the relevant steps if and when I experience further difficulties. Hopefully this was just a one-off situation. Daniel
Sign In or Register to comment.

Who's Online30

Bernd L
Bernd L
heylia
heylia
jarso70
jarso70
Lochfrass
Lochfrass
porter652_un43
porter652_un43
+25 Guests