Sports watch activities won't upload to TomTom Sports platform — TomTom Community

Sports watch activities won't upload to TomTom Sports platform

SawtoothSawtooth Posts: 2 [Apprentice Traveler]
I've been using and like the TomTom Sports platform for keeping track of my activities and progress. But over the last few weeks, when I connect my watch I get a message that my activities can't be uploaded and I should try again later. I keep getting the same error and sometimes the activities, which I can see are on my watch still, just won't upload. It looks like the Sports platform is failing. Any tips?

Comments

  • tfarabaughtfarabaugh Posts: 16,676
    Superusers
    Are you syncing through the app or a computer? You can force the activities to upload by following these steps:

    1. Exit MySports Connect on your computer (you must use a computer to reupload – right click on the tray icon and select Exit).
    2. Locate the ttbin files:

    PC:
    The ttbins are saved in a dated folder for the date of the activity under C:\Users\{User Name}\TomTom MySports\{Watch Name}

    Apple Devices:
    a. Connect your iOS device to your computer and wait for iTunes to open.
    b. Select your iOS device in the iTunes sidebar.
    c. Select the Apps tab and scroll down to File Sharing.
    d. Select MySports.
    e. The ttbin files are listed on the right hand side.
    f. Right-click (Mac: ctrl-click) a file to copy it and save it to your computer

    Android Devices:
    a. In Android, the ttbin files are stored on the internal SD in (/sdcard/TomTom_MySports/[serial number of watch]/workouts/uploaded/).
    b. Copy them to your computer

    3. Place the ttbin files in the serial number directory:
    Windows: C:\Users\[user name]\TomTom MySports\[serial number]
    Mac: [home dir]/TomTom Sports/[serial number]
    4. Restart MySports Connect and connect your watch
    5. Go the Settings page (click the gear icon on the top right) and press the 'Try again' button to re-upload the files.

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • SawtoothSawtooth Posts: 2 [Apprentice Traveler]
    Thank you, yes I am trying to upload from the watch to a MacBook Pro. I will try this but it looks like a good solution!
  • bolton_ianbolton_ian Posts: 9 [Legendary Explorer]
    I'm trying to upload a run and my watch isn't letting me.
    It's showing on my watch, yet it won't upload to my activities and I'm getting very annoyed.

    I've followed the advice on here, up to this point (I'm on a Mac by the way), but I really don't understand what I'm meant to do here:
    3. Place the ttbin files in the serial number directory:
    Mac: [home dir]/TomTom Sports/[serial number]
  • vasily.zavyalov_un33vasily.zavyalov_un33 Posts: 1 [Apprentice Traveler]
    Exactly the same issue I've faced recently and a few posts around found the solution that worked for me on mac: http://uk.support.tomtom.com/app/answers/detail/a_id/17391/~/re-exporting-activities-that-failed-to-upload

    In short, placing '.ttbin' file under '~/TomTom Sport', disconnect-watch-restart-app-connect-watch cycle finally pushes that '*.ttbin' file.

    «Click Finder > Go > Go to folder and type '~/TomTom Sport'»
  • thewrongtrousersthewrongtrousers Posts: 12 [Master Traveler]
    Just had this happen, the activity shows on the watch but won't upload to Sports, I've checked

    C:\Users\{User Name}\TomTom MySports\{Watch Name}

    but there is no file for todays date, I have also checked yesterdays day and there is no ttbin file.

    Any ideas?
  • slinslin Posts: 70 [Supreme Navigator]
    edited May 2019
    The information the watch displays, is an short review from
    your activities. It does not mean the ttbin is on the watch!

    You can simply try to download an activity "once"! if this
    fails, the activity is lost forever.

    I recommend using ttwatch (linux) to download the ttbin
    from the watch. I never had any lost of data using this tool,
    but using the TomTom Software i had lost of data several
    times.

Sign In or Register to comment.

Who's Online in this Category0