Latest update killed my Spark

flyingmountaindaily
flyingmountaindaily Registered Users Posts: 1
New Traveler
edited January 24 in TomTom Sports
I plugged in to charge the watch this morning and was notified I needed to update, which I did. I received the "whoops, something has gone wrong" error, and have since tried everything support pages have described including soft reset, hard reset and forced reset, but receive the same error message each time. Up until this morning, I had a great watch! But after connecting for the latest update, the watch no longer works. Any suggestions? (It's too light to be an effective boat anchor!)

Comments

  • tfarabaugh
    tfarabaugh Posts: 17,004
     Superuser
    At this point I would suggest calling Customer Support to see what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to tomtom.com/support, choose Contact at the bottom, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.