Renault Clio Map Can't Be Used — TomTom Community

Renault Clio Map Can't Be Used

EjchawkerEjchawker Posts: 2 [Apprentice Traveler]
edited November 2020 in Built in car navigation
Hi, I have a Renault Clio (Dynamique Tom Tom model) which I bought as new in 2012. I've been using the Tom Tom satnav in it quite happily up until July this year when one day when I started the car, a message popped up saying "Problem with map: This map cannot be used - United_Kingdom_and_Republic_of_Ireland".
Up until that point the original Renault SD card had never been taken out of the car, but I assumed something had happened to the map file so I plugged it into my laptop and installed the Tom Tom Home app as prompted. It then had lots of critical updates which I let it do on my laptop and told me my device had some map and other updates available. I thought maybe updating would fix the issue so I accepted the updates (after doing a backup to my PC as prompted) which took forever but I followed the instructions which involved swapping the SD card between the car and my laptop a few times while it did additional updates. After it finished it loaded up in the car and I got the exact same error.

At that point I got a bit fed up with it and ran out of time so left it alone, and started using Google Maps on my phone ever since. Now however, I need to use the car satnav more so need to get this fixed so having another go. I have tried restoring the original software/maps to the SD card from the first backup I made in July and checking the map file is present on the SD card which it seems to be in windows explorer and going to manage my device in Tom Tom Home but still stubbornly get the same error.

Next I have tried deleting the map from the SD card, assuming I could re-download it if it had got corrupted somehow, but then when I click update there is no map option to update any longer so I restored the map from the backup again as that seemed not to be an option.

Bit stuck on what to do next. Can someone advise what I can do to get my original map working again in my car? I'm not bothered which map I use (the original 2012 one or a new one but don't want to pay for an update if it costs as the original maps that it came with still work fine for me).

Many thanks,
Emma

Comments

  • VikramKVikramK Posts: 11,902 Moderator
    Hi Ejchawker

    Welcome to the community:)

    I have assigned the map of UK and ROI on your account and you should be able to download it using TomTom HOME.

    However, I would first recommend you to remove the existing map and then download the one which gets offered.

    Remove map- FAQ:https://uk.support.tomtom.com/app/answers/detail/a_id/6953

    Download map FAQ: https://uk.support.tomtom.com/app/answers/detail/a_id/24642

    Hope this helps:)

    Regards
    Vikram
  • EjchawkerEjchawker Posts: 2 [Apprentice Traveler]
    Hi Vikram, Thanks very much for your help. This solved the problem, I was able to download the map again and now it's working again. Thanks again!
  • BettyboopBettyboop Posts: 4 [Apprentice Traveler]
    Dear moderator,

    I have the exact same issue. 2012 Clio, the only map I have available in the car is UK and ROI but when the Sat Nav starts up, it tells me that I can’t use that map “on this device”. But as I say, it is the only map available.

    Can you help?

    Thank you
  • DougLapDougLap Posts: 7,966
    Superuser
    Hi @Bettyboop

    Hopefully @Jim07 can sort out your map. Look back here later

    Doug
  • BettyboopBettyboop Posts: 4 [Apprentice Traveler]
    Hi @DougLap,

    Thank you for your very speedy response. I’ll keep an eye out.

    Thank you again.
  • BettyboopBettyboop Posts: 4 [Apprentice Traveler]
    Hi @Jim07,

    Is this something you can help with?

    Thank you
    S
  • lampardlampard Posts: 5,312 Moderator
    Hi @Bettyboop

    Sorry for the delayed response! The UK and ROI map should be offered to you in TomTom HOME now to download. Please remove the existing map on the device and install the one which is offered.

    Regards, lampard
  • BettyboopBettyboop Posts: 4 [Apprentice Traveler]
    @lampard Thank you so much!

    Just deleted the old and downloaded the new and all appears to work - will take a drive tomorrow to give it a proper test, so fingers crossed.

    Thank you again.
Sign In or Register to comment.

Who's Online in this Category0