TomTom Curfer will not activate

JOHNO45JOHNO45 Posts: 1 [New Traveler]
edited January 30 in TomTom Curfer
I bought a Curfer over a year ago and it was installed and running beautifully, unlike the vehicle it was installed on and I had to return the car to the supplying dealer.

Today, I found the Curfer whilst sorting out and wanted to install it in my new (to me) car.

It plugged into the OBD without a problem and the blue light came on solid and the green light flashed as expected.

I went to the app and found that the data from the previous car was still in place and I was unable (could not find a way) to delete / reset it. So I deleted the account and re-registered. The email arrived, I clicked on the link and all appeared well.

I then went through the login process in the app that prompted for the make, model and year of car. I entered all of that and the switched on bluetooth and internet (right outside the house with the router on the other side of the window). There was a little message that suggested that the Curfer was connected (paired) with my phone.

I clicked next to select the activation process. It sat there for ages with a spinner animation, but nothing happened. So half an hour later I went into the house and surfed to find an answer to the problem, but without success.

I logged into TomTom with the new account and started this post and then had a flash of inspiration, maybe the Bluetooth pairing was not activated and sure enough, that is what the problem was. The message in the setup was just that, not a true indication of the status of the connection. So I went into the phone settings, found the device, connected it and low and behold the activation completed in less than a minute.

Software update downloaded to the Curfer and we are away.

I almost delete this post, but thought someone else may have the same experience and this might save them some time and frustration.

Happy Curfing.

Comments

  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi John,

    Welcome to the Community!

    Thanks for sharing your experience! I'm sure it'll help others to avoid the particular pot hole you encountered :D The following FAQ has some more tips regarding connection.

    CURFER doesn't show in Bluetooth® device list[/uel]

    Cheers, Mikko
  • via247via247 Posts: 41 [Outstanding Wayfarer]
    Hi, I have what appears to be a similar problem. Basically, it worked without a glitch for about a month and then went to Switzerland and noted after about 600 miles nothing! Can’t log in, can’t trace my login info, tried everything for almost an hour and gave up. Same vehicle, same unit and phone but will not log into account ! Tried creating another account and it says it’s being used by another person (me)! Tried resetting password but nothing is recognised. It’s a silly system trying to recover passwords given if you can’t recall name or email then the process is doomed. My iPhone usually remembers this info but in this case nowt! Help !
  • lampardlampard Posts: 3,686 TomTom Moderator
    Hi via247,

    Welcome to the Community & sorry for my late reply!

    It seems that you created two usernames with the same email address. I've sent you the PM regarding your username, please check and confirm if you're able to log in.

    Cheers, lampard
  • via247via247 Posts: 41 [Outstanding Wayfarer]
    Hi, sorry have no idea where to view the personal message. You might be right ref same email account with two user names but I did not disconnect the CURSER originally. However, I have yet to resolve the problem even after deleting the app, re-installing and disconnecting CURFER, re-registering with new user name and email account - still won’t connect says its being used by another account holder (Me). I have reported this to Tomtom given this is actually what was recommended by them. At the end of the day I have concluded the CURFER has stored login data of its own and thus this needs to be purged - anyway, can’t see this being resolved this side of Christmas!!!
  • peagee2017peagee2017 Posts: 1 [New Seeker]
    I am having exactly the same problem. I hadnt used my curfer for a while so forgot my username. Went through the whole process like via247 described and still getting the same message but try as I may I can't even find a way to contact the company for advice.
Sign In or Register to comment.

Who's Online34

DougLap
DougLap
Eilis
Eilis
mfrederic2
mfrederic2
+31 Guests