Many problems. Connecting and adding subscription — TomTom Community

Many problems. Connecting and adding subscription

eddierockseddierocks Posts: 4 [Apprentice Traveler]
:(Hi.
I`m having so many problems getting this app to work.
I`ve had to change my phone from a Sony Z5 to a Sony XA1
After installing on the new phone, it does not recognise my email address to add my current subscription.
After many un installs and reinstalls, it now cannot find a connection for install again.
"Retrieving settings from TomTom........"
"Can`t connect to Tom Tom. Try again later"

I`ve done all the clear cashes thats been submitted
Please help.

Comments

  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Eddie,

    Welcome to the Community!

    Please, follow the steps below to get this sorted:
    • Uninstall the app
    • Clear cache data for the following apps (note, going to Settings > Applications / Manage Applications, might not show them. Via the 'More link in the top right corner, enable 'Show System Apps'):
      Google Play Services,
      Google Play Store,
      Google Services Framework.
    • Set the time to "automatic"
    • Restart the phone (this is important)
    • After the phone restarts check and make sure their internet browser has access to the internet with wifi and/or 3g/4g
    • Download a fresh copy of the app from the Google Play store
    • Install and test

    Cheers, Mikko
Sign In or Register to comment.

Who's Online in this Category0