Download your MyDrive data doesn't work — TomTom Community

Download your MyDrive data doesn't work

tevgegtevgeg Posts: 2 [Apprentice Traveler]
Hello,
i have an issue, when I click on "Download your MyDrive data" in the Settings of MyDrive, it simply doesnt work.
I checked on Chrome and IE latest versions. Could someone clarify/confirm it's working? I'd like to download favorites.

Additional question: is there any easy way to export favorites from TOMTOM/Mydrive to Sygic ? give me some tips please where to look for.

Comments

  • YamFazManYamFazMan Posts: 20,053
    Superusers
    Hi
    Many users have asked for the facility to backup their MyPlaces in the MyDrive Web (v2) Route planner to a PC
    I've posted this How to guide using the method developed by User GEB
    Link to Post.....
    https://en.discussions.tomtom.com/mydrive-connect-apps-474/faq-what-mydrive-and-what-can-i-do-with-it-990620?postid=1159989

    ATB YFM
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi tevgeg,

    Welcome to the Community!

    We had an issue with this earlier and some customers were unable to download the data using IE or Firefox. That issue has, however, since been resolved.

    Could you elaborate on your issue a bit more so that we can better help you, please? What happens when you try to download the data? A screenshot would be helpful as well.

    As MyDrive works in a browser, most issue, especially having to do with user data, can be solved by clearing the browser cookies and cache.

    Cheers, Mikko
  • user12345user12345 Posts: 1 [Apprentice Seeker]
    Hi MikkoK,

    I am also trying to download my TomTom data but it doesn't work. After I clicked the "Download your MyDrive data" link in the "Settings", the browser showed briefly "Waiting for mydrive.tomtom.com..." in the status bar and then nothing happened. I have tried this with a few different browsers (Chrome, IE, Firefox and Opera) and on different computers. As I remember I used this feature quite a while ago and it was working back then.

    Can you let me know if this feature is still functional?

    Thanks.
  • YamFazManYamFazMan Posts: 20,053
    Superusers
    Hi
    @user12345

    Unfortunately MikkoK has left Tomtom
    ________________

    Downloading your MyDrive data is working here....
    IE11... OK (But very slow Map re-draw)
    MS Edge... OK
    Chrome... Is opening the file in Notepad ???
    Firefox... NO

    The file type has now changed from a .txt file to a zipped .gz file type

    ATB YFM
  • bigbig Posts: 1,670
    Superuser
    Could it be it really is downloading but doesn't give any notification that it's done so? Can you check your download location?
  • gildersleevegildersleeve Posts: 8 [Apprentice Seeker]
    this bug seems to be back, i am unable to download data not sure if related but problem started around time critical wifi update was released 19th sep ...!
  • Lost_SoulLost_Soul Posts: 289 [Supreme Pioneer]
    I have been trying for the last day or so to download MyDrive data; I usually do this in the first week of each month as part of my process of syncing favourites with my other PND's, but was distracted by events in September, so cannot comment when this issue arose.

    I use Google Chrome as my usual browser but also tried other browsers without success, after rebooting my PC, downloading a clean copy of MyDrive and clearing cookies / caches but all this made no difference.

    I have recently added quite a few more places on my devices and this is the only way that I can backup that information as there is no way to interrogate our devices by connecting them to a PC for example.

    I therefore regard this as an important process to maintain the data integrity of our devices.

    @lampard @VikramK Can you bring this the attention of the relevant personnel soonest please
  • VikramKVikramK Posts: 12,678 Moderator
    edited October 2019
    Hi @Lost_Soul

    We are looking into this now..

    Sorry about the goof-up...

    I will post back..

    Regards
    Vikram
  • Lost_SoulLost_Soul Posts: 289 [Supreme Pioneer]
    Hi @VikramK

    Thank you. :)
  • Lost_SoulLost_Soul Posts: 289 [Supreme Pioneer]
    Hi @VikramK

    The download MyDrive data has started working again =)

    Thanks
  • VikramKVikramK Posts: 12,678 Moderator
    Hi @Lost_Soul

    The team implemented some fixes in all environments. Some more bug fixes and improvements are planned.

    Thanks for confirming..

    Regards
    Vikram :)
  • gildersleevegildersleeve Posts: 8 [Apprentice Seeker]
    now able to download using internet explorer but still not working im firefox browser
  • Lost_SoulLost_Soul Posts: 289 [Supreme Pioneer]
    VikramK wrote: »
    Hi @Lost_Soul

    The team implemented some fixes in all environments. Some more bug fixes and improvements are planned.

    Thanks for confirming..

    Regards
    Vikram :)

    Hi @VikramK

    Good to hear that improvements to MyDrive are planned.................. =)

    There is one "bug" that has been outstanding since July 2017 :'(

    We used to be able to use Mapcodes on MyDrive (web) but after an update back in July 2017 for search improvements ;) this facility was no longer available which is a pity as it was a facility I used as we often drive to rural destinations at night where it can become an issue to locate our final destination based on post codes which may take you up to 1/2 mile away................. :/

    I know we can still input map codes on the PND itself, however being a bit lazy (and easier to use a PC keyboard too) I prefer to use MyDrive first and then send the location to the device, so that when we get into the car we are then ready to go........... =)

    A TT moderator (now retired @MikkkoK) said back in July 2017:

    "I got a confirmation that this indeed has to do with the recent release. The team is aware of this and will address the matter in a later release. Unfortunately, I don't know the exact release date.

    Cheers, Mikko"

    Still waiting 2 + years later !!! :persevere:

    It would be good to know this is still on the cards for inclusion in a later release; especially as Mapcodes were invented by then TomTom's Pieter Geelen and Harold Goddijn - CEO ;)
  • shed53shed53 Posts: 6 [Apprentice Seeker]
    I have just tried to download my MyDrive data on three different browsers but got the same behaviour every time. Very briefly, a link is flashed up, so quick I can't read it, but I suspect it is "mydrive.tomtom.com" then nothing happens. I've checked my Downloads folder but there is nothing there. I'm using Windows 10 and I tried Edge, Vivaldi and Firefox. With Firefox, I cleared my entire history including cookies and cache - but still no joy.
    Please can anyone shed any light on this?
    I have recently bought a car with a built-in satnav based on TomTom so I want to import all My Places from MyDrive to this new system.
    Hopefully...
  • YamFazManYamFazMan Posts: 20,053
    Superusers
    edited August 2020
    Hi
    @shed53
    Welcome to the site....
    You can create a Personal POI Category of your MyPlaces to replace the MyPlaces list, and their Icons on your device

    Or even Create Multiple Personal POI Categories as required ....


    Many users have asked for the facility to back up their MyPlaces to a PC
    The Tomtom MyDrive Web Route planner....
    i.e... the Tomtom Cloud
    Here... https://mydrive.tomtom.com

    The MyDrive Web Route planner allows you to download your data from the Tomtom Cloud
    3d6xrq52c0wz.png
    The file looks like unusable Gobbledegook, but the MyPlaces can be found in the file
    Click on image to enlarge....
    x3keyqdqe377.png

    Note... If you are having problems downloading the .json.gz file from the MyDrive Web Route planner... Clearing your Web Browser cache should fix the problem....
    For more info See... https://discussions.tomtom.com/en/discussion/comment/1721554/#Comment_1721554
    ___________________________________

    User Ethoz....
    Posted a link to an excellent Tomtom MyPlaces to .Ov2 POI file converter tool
    https://translate.google.com/translate?hl=en&sl=de&u=https://chbworld.net/software/tomtompoi.html&prev=search

    There's a Mac & PC version ....

    Download and install TomtomPOI.exe from the above link
    Note... I have Virus checked the file with Avast Anti Virus all OK
    Run TomtomPOI

    Ist Click on Open...
    948al3lvjrtz.jpg
    A New Filer Window opens
    Find & Select the (Your user name goes here)_MyDrive.json.gz file
    Saved from the Tomtom MyDrive Web Route planner
    Click on the 'Open' Box

    wszajd139ty2.jpg
    2nd Click on Copy
    bsndf6o7jzm7.jpg
    3rd Click on Yes
    5567983e-03cb-46bc-a0f8-c09e5d822af2.png
    4th Click on Yes
    0d841302-e88f-4af0-bb4a-764126dc21d6.png
    5th Click on Save
    a8fe2080-c483-47ce-b413-b1606cd50aba.png
    Name the .Ov2 file & Save to the PC Desktop
    ___________________________
    ___________________________

    Install your Personal POI Category....

    Installing 3rd party POI Categories... You use the MyDrive Web Route planner
    Here... https://mydrive.tomtom.com

    See Tomtom Video... How to import POIs, GPX files and Favourites in MyDrive


    If Required... Displaying Personal POIs on the Driving View/Map
    Be aware... You can't install the POI associated .BMP files
    You can only use the 5 Tomtom supplied generic Icons....

    13s1zlb8gssy.jpg
    But you can use one icon for for more than one POI category i.e... place all your fuel categories under one Icon, then if you tap on a nearby 'say' Fuel Icon a Quick menu opens --> Tap the 3Dot Icon for more options & more Information

    Setup... After installing your Personal or 3rd party POIs....Tap 4Dot (....Menu) --> Settings --> Appearance --> Show POI lists on the Map
    It says a restart is required, but I've never found it to be necessary
    After choosing the Generic Icon.. Tap the coloured (^) Icon screen top right... Pinch zoom the Map, the Generic POI Icons all appear live and working
    Note... The Generic POI Icons disappear when the Map is highly zoomed out (I guess so you can scroll around a clear Map to find your location)
    The Icon reappear as you zoom back in again

    Here the Yellow Pentagon Icons --> National Trust
    fwsmyemsot57.jpg
    __________________________
    __________________________

    Maybe Useful... Searching an installed 3rd party POI Category....
    The search engine is excellent you usually only need to type around three characters of the POI name for a hit...
    For example... I have loaded the 3rd party POI's for the National Trust... To show the POI's for "National Trust" on the map, work your way down to option (2)

    From the main screen
    Tap (....)4Dot Icon (Screen Bottom left)
    Swipe left or Tap the mid/right edge of the screen to go to and tap the MyPlaces Icon
    Scroll down and select the required POI Category For example "National Trust"
    You now have three options
    The Main search area turns blue and "National Trust" is offered with a flashing cursor
    Continue typing the name of the required "National Trust" site, Type Dud (Or as much of the word that's required for Dudmaston Hall appear at the top of the National trust list)
    Tap on the offered Dudmaston Hall and select the Drive Icon

    fvvl1hj389eu.jpg
    You also have two further options.....
    After the initial "National Trust" POI selection
    There's a dual Icon (screen bottom right) with Three Lines and Two circles

    o7rx4qycdyey.jpg
    (1)..... Tap the three Lines Icon (bottom right screen) and a list will appear of the "National Trust" sites in distance order
    (2)...... Tap the Two circle Icon for the "National Trust" sites POI's to appear on the screen (Pinch zoom for detail) (Note..... On the Start range its easier to tap the plus and minus buttons to zoom the map screen)
    as far as I'm aware it will show the nearest 60ish POI's around your location
    There is also a Keyboard Icon (screen bottom right) to return to the search window from the options (1) and (2)

    An example of the generic Icons on the search screen, the Icons are dynamic so the closer you zoom more icons appear

    j381fa0ut3qg.jpg
    Stay safe.... ATB YFM
  • shed53shed53 Posts: 6 [Apprentice Seeker]
    Hi @YamFazMan

    Thanks for this comprehensive reply. There's lots of helpful stuff in there, but my problem is that that the link to download my data doesn't work in the first place, so I can't use any of the tools you describe to manipulate the downloaded data.

    I log on to mydrive.tomtom.com successfully. I click on Settings, then choose the MyDrive tab, then click on the link "Download your MyDrive data" as per the first screenshot in your reply.
    * In Microsoft Edge, I get a white square over the top of the webpage for 1-2 seconds, then I'm back where I was but with nothing about any download.
    * Using Google Chrome, nothing at all appears to happen.
    * In Firefox, a message appears for less than a second at the bottom of the browser saying "waiting for mydrive.tomtom.com..."

    Do you have any suggestions for how to resolve this?
  • YamFazManYamFazMan Posts: 20,053
    Superusers
    edited August 2020
    Hi
    @shed53

    Post edited 24/08/20... Rechecked the download of the .json.gz file from the MDW Route planner using Chrome, Microsoft Edge & Firefox....
    All 3 failed to download the .json.gz file....

    As user 'Lost_Soul' says in the following post the fix is to clear the Browser/s cache....

    Here after clearing the Browse caches ... Chrome & Microsoft Edge open a small Window on the MyDrive Web Route planner screen bottom left... Also, Chrome & Microsoft Edge autosave the .json.gz file to your Windows 10 → (Your Computer Username) → Download folder....

    n8jhxvfrwnq8.jpg
    Firefox opens the normal small 'Open or Save' window to save the .json.gz file... Firefox doesn't autosave the .json.gz file

    Stay Safe ATB YFM
  • Lost_SoulLost_Soul Posts: 289 [Supreme Pioneer]
    @shed53

    This issue occasionally occurs for me too - last Thursday to be precise. :)

    I am using Google Chrome with Win 10 and find that by "Deleting All Tomtom" cookies and then signing back in again to MyDrive it normalaly then allows the download file to be created. I also have had to shut Google Chrome down and reload after clearing the cookies before the download would commence.

    Hope it works for you.
  • shed53shed53 Posts: 6 [Apprentice Seeker]
    Thanks @Lost_Soul and @YamFazMan for your answers last week.
    Sadly, I'm still getting the same behaviour :anguished:
    I tried 3 different browsers (Edge, Chrome, Firefox) and with each one, I logged out of TomTom's MyDrive, cleared all browsing data (and with Edge and Chrome I also signed out of Microsoft and Google respectively), closed down the browser and restarted it. I still got nothing when I clicked on "Download your MyDrive data".
    I'm now wondering about raising a bug report with TomTom themselves :pensive:
  • YamFazManYamFazMan Posts: 20,053
    Superusers
    edited August 2020
    Hi
    @shed53
    Edge, Chrome, Firefox... Working OK Here
    Have you looked in the Folder....
    C:\Users\Your Computer name goes here\Downloads....

    Stay Safe ATB YFM
  • Lost_SoulLost_Soul Posts: 289 [Supreme Pioneer]
    Hi @shed53

    I just tried downloading the MyDrive data and got the White square flashing and no Mydrive data download, so there does seem to be a bug or incompatibility continuing....... . :s

    Using Google Chrome on Win 10 I went to:

    Settings
    Cookies and other site data
    See all Cookies and other site data

    Searched for all "Tomtom" Cookies and then said delete all.

    Went back to myDrive - pressed F5 to refresh , had to accept cookies and sign back in: I then was able to download the MyDrive data.

    Are you getting the message of having to accept cookies etc when you go back to MyDrive after doing your clearing action?
  • shed53shed53 Posts: 6 [Apprentice Seeker]
    Hi @YamFazMan
    Yes, thanks, I did look in my Downloads folder. I even made sure I knew where the browser was putting downloads.
    I see @Lost_Soul has also added another reply, so I'll check that out...
    Thanks for keeping an eye on this thread.
  • shed53shed53 Posts: 6 [Apprentice Seeker]
    Hi @Lost_Soul

    I didn't explicitly look for TomTom cookies. I cleared all cookies and when I went back to clear again (I'm that sort of guy :wink:) it said "0 bytes".
    However, that may not have done what is needed so I'll follow your recipe. About to go into a meeting so later. Watch this space...
    And thanks also to you for continuing to contribute to my quest.
  • shed53shed53 Posts: 6 [Apprentice Seeker]
    Hi @Lost_Soul

    I followed your instructions and I did find some TomTom cookies - which I deleted. Sadly though, I still experience the same behaviour. A brief message bottom left of the browser window "Waiting for mydrive.tomtom.com..." :anguished:

    I tried Firefox again, with the cookies display open (from Options | Web Developer | Storage Inspector). Each time I click on "Download your MyDrive data", a specific cookie is briefly highlighted in yellow. I have no idea what that means.

    I'm back to thinking I should raise a ticket with TomTom themselves. Does that seem like an appropriate next step?
  • Lost_SoulLost_Soul Posts: 289 [Supreme Pioneer]
    Hi @shed53

    Probably best to raise a ticket with Tomtom, that method I described has always worked for me, but as I experienced the same issue as you; there does seem to be a bug or incompatibility continuing........ :/

    Good luck.
Sign In or Register to comment.

Who's Online in this Category0